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Modify Record 
Version Data Description 

R1 2023.08.16 1st version established. 

1 Product Introduction 
NcStudio V15 Laser Plane Cutting Control System (LS2000M) is referred to as 
LS2000M. Suitable for laser plane cutting of 6000W and below. 

Product Feature: 

 Support focus control. 

 Support slow start/stop technic adjustment to ensure cutting effect at start/end point. 

 Support multiple exchange workbench external device control. 

 Support camera monitor. 

 Support multiple automatic edge finding methods. 

 Support bus torque anti-collision. 

 Support quick one key cut sheet. 
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2 Software Main Interface 
Through this part, you can quickly become familiar with the main software interface of 
LS2000M. 

LS2000M support horizontal and vertical screen adaptive switching. This article uses the 
horizontal screen as an example to introduce the software main interface. The main 
interface is as follows: 

 
1. Menu bar 
2. Common Toolbar 
3. Control Bar Display Button 
4. Machine Tool Control Bar 
5. Layer Toolbar 
6. Drawing Area 
7. Machining Information Statistics Column 
8. Alarm/System Information Bar 
9. Drawing Information Bar 
10. Drawing Toolbar 

2.1 Common Toolbar 
Button Description 

 New Create a new toolpath file. 

 Import Import G, NC, DXF, DWG, PLT, LXD, CNC format files. 

 Open Open NCEX format file. 

 Save Save the tool path file. If save the new tool path file, click and save as NCEX 
format file. 

 Undo Undo the last action. 

 Redo Restore the undo operation. 
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Button Description 

 Show Order Show or hide the machining sequence. 

 Show 
Direction 

Show or hide the machining direction. 

 Highlight 
Unclosed 
Objects 

Display all unlocked graphics in special color (red) or not in special color. 

 Catch Options 
Set the features to be catched. Switch entry for catch function: In the menu bar 

click Drawing → Catch. 

 Select all, select invert, clear selected, and auto select unclosed, select tiny, 
inner, outer, select similar, etc. For details, please see Auto Select. 

 Translate / rotate graphics and perform vertical and horizontal mirror of 
graphics. For details, please see Translate, Rotate and Mirror. 

  Scale the graphic proportionally and change the size of the graphic. For details, 
please see Size Scale. 

 Group selected objects into a group. For details, please see Group. 

 When a single Group is selected, disband the group into multiple shapes. For 
details, please see Ungroup. 

 Perform pre-process operations on graphics, including Merge, Explode, 
Smooth, Curve Segmentation, Delete Overlap Line, Delete Tiny, Simplify 
Curve, Convert Polyline to Circle, Trim Self-intersection, Convert Text to 
Graphic. 

 When single or multiple objects are selected, open the Instant Pre-process 
dialog box to make setting. For details, please see Preprocess. 

 Set the machining direction. For details, please see Machining Direction. 

 Reserve a small distance without cutting (reserve gap) to connect the 
workpiece and the plate together. For details, please see M-joint. 

 Set machining lead-in and lead-out lines. For details, please see Lead. 

 If there is a lead line, set the start point/end point of the lead line; if there is no 
lead line, set the start point of machining, and start machining the graphic from 
the selected current point. For details, please see Start Point. 

 A seal is formed between the cutting start and end point of the part, and the 
seal method is divided into gap and overcut. For details, please see Gap. 

 Set unfill and fill. For details, please see Unfill/Fill. 

 Compensate actual machining kerf error. For details, please see Kerf 
Compensation. 

 Connect two shapes like a bridge. For details, please see Bridge. 

 Remove burrs from parts caused by machining. For details, please see 
Chamfer. 

 Move the graphic berth to the workpiece origin. For details, please see Berth 
Point.  

 Set unfill/fill, lead line, machining direction, machining sequence and kerf 
compensation at one time. For details, please see OC-Set.  
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Button Description 

 Process the co-edge between graphics so that share a boundary. For details, 
please see CoEdge. 

 Specify the machining order of graphic in the tool path file. For details, please 
see Sort. 

 
Find the most efficient path for machining, eliminating lift and cut steps. For 
details, please see Scan. 

 Copy and arrange the machining graphic in order. For details, please see 
Array. 

 Arrange machining parts to improve material utilization and machining 
efficiency.For details, please see Nest. 

 Clear part machining technic that has been set. For details, please see Clear. 

 Calibrate the cutting head. For details, please see Calibrate Cutting Head. 

 Focus Control function is used to automatically adjust the focus during 
machining. For details, please see Focus Control. 

 Set commonly used machine tool control parameter, follow-up control 
parameter, and unit switching. For details, please see Common Parameter. 

2.2 Control Bar Display Button 
Show or hide the Machine Tool Control Bar. 

2.3 Machine Tool Control Bar 
The machine tool control bar includes: 

 Coordinate Display Area 

 Manual Axis Control Area 

 Machine Tool Control Button 

2.3.1 Coordinate Display Area 
Display the workpiece coordinates, machine coordinate, feedback coordinate, low speed, 
rapid speed and step distance of each axis: 

 
After the return to machine origin is successful,  mark will appear in front of each axis. 

In this area, can perform the following operations: 

  Click  to switch between workpiece and machine coordinates. 

  Click  to set the low speed, rapid speed and step distance of the X/Y-axis and 
Z-axis separately: 
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2.3.2 Manual Axis Control Area 
Axis description: 

 X/Y-axis: The X/Y-axis is the axis that control the forward and back/left and right 
motion of the cutting head (the control mode use position loop control). 
Generally, the Y-axis is used to control the gantry axis and is divided into two drives, 
Y1 and Y2. The X-axis is generally used to control the cutting head to move left and 
right. There are also situations where the X-axis is used to control the gantry axis, 
such as the "Bond" machine tool. At this time, the gantry axis is divided into two axes: 
X1 and X2. 

 Z-axis: Z-axis is the follow-up axis (the control mode is speed loop control), which is 
used to control the cutting head up and down motion. 

Manual motion is divided into two types: jog and step mode. The switches for the two 
modes are as follows: 

 
When using the handle to switch manual jog/step, press the Step button to switch. 

2.3.2.1 Jog Mode 
There are two modes: Rapid and Low in manual jog mode. The switching path is as 
follows: 
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Note: When using the handle to switch manual rapid / low, need to keep pressing the 
rapid button on the handle. After releasing it, the current mode will change to the mode set 
on the software interface. 

The corresponding rapid/low motion speed can be set according to different speed needs: 

 
It can be set in the system parameters. The specific setting position is: System 

Parameters → Speed Accuracy → 2.0 Jog Speed → 2.0.0 Jog Speed. 

 
After setting the motion mode and speed, click the direction keys to move the 
corresponding axis for movement. 
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2.3.2.2 Manual Step 
Manual step mode can set the corresponding step distance to move the target axis to the 
desired position. 

 
The speed of manual step is set in the system parameters. The specific setting position is: 

System → System Parameters → Speed Accuracy → 2.0 Jog Speed → 2.0.0 Jog Speed. 

 
After setting the manual step distance and speed, click the direction key corresponding 
axis will move to a step distance position. It cannot be executed when manual movement 
is executed again during the movement. Only after step into the arrival target position, the 
system enter idle state can execute the next action. 

2.3.2.3 Override Adjust 
There is an override adjust function in the operation bar, which can adjust Auto Frp and 
SIM Frp.  

 
 Auto Frp 

Auto Frp adjust the speed of non-simulation motion. The adjusted machining 
override not only affect the speed during machining but also affect the speed of 
manual motion.  
Actual movement speed = set speed × machining override 
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 SIM Frp 

SIM override is only effective for simulation machining and has no effect on other 
motion forms. 
Actual SIM speed = SIM speed × SIM override 
When simulating motion, the machine tool is not controlled to execute 
corresponding machine electrical actions, and only the machining trajectory is 
displayed in the object edit area. The trajectory running speed is the simulation 
speed. If you want to accelerate simulation speed, in addition to modifying the 
simulation override, you can also modify the cutting speed in the layer. 

 
2.3.3 Machine Tool Control Button 
Start and stop machining and execute and laser cutting related operations: 

Button Description 

 

Set the workpiece coordinate of the current coordinate system to zero. 

 

Return to workpiece origin. 

 

Execute all axes to return to machine origin. 

 

Execute the Z-axis return to machine origin. 

 

Calibration refer to capacitance calibration. Its main function is to collect capacitance 
data and match the relationship between the distance between the cutting head and the 
cutting plate and the capacitance feedback of the cutting head. 

 

Start the machining task from the beginning. 

 
Stop this machining task. 
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Button Description 

 

After machining stop, if the machine coordinates are ensured to be accurate, machining 
will resume from where the last machining stopped. If set system parameter Break 
Distance When Breakpoint Continues, then resume machining from (last machining 
stop + breakpoint resume back distance). 

 
When machining stop, click this button to position the last machining stop point. If set 
system parameter Break Distance When Breakpoint Continues, then resume 
machining after positioning to (last machining stop point+ breakpoint resume back 
distance). 

 

Enter simulation mode. The system does not drive the machine tool to perform 
corresponding machine electrical action and only high speed simulate the machining 
path in the drawing area. 

 

Enter track mode. Run the machine tool without open the laser and machining related 
ports to check whether the machining action is correct. 

 

The laser head walk around the outer frame of the graphic to be machined and create a 
rectangle, which is used to determine the machining range and position of the plate. 

The speed of cut frame is set in System → Common Parameters → Machine Param → 

Frame Check Speed. 

 

During machining, only the selected graphics are machined, including machining, track, 
simu, frame and resume. 

 

Control the Z-axis to float up and down in real time to ensure that the relative distance 
between the cutting head and the plate remain unchanged. 

 

Calculate the rotation angle of the current plate relative to the machine coordinate 
system, rotate the workpiece coordinate system in the tool path by the corresponding 
angle, and establish a new workpiece coordinate system. 

 

Manually control the cutting head jog light once. 

 

Manually cut off the plate, distinguish between thin and thick plate, and can set the 
operation direction, cutting technic and cutting speed. 

 

Before start machining, click to turn on the laser power. 

 

Click to open the shutter, and then click to close. The shutter must be manually clicked 
open. First open the shutter and then open the laser valve to release the laser. 

 

Press and hold the laser valve until it is released to close. When machining start, the 
system automatically open the laser valve. 

 

Click to turn on the red light, and then click to turn off, it must be turned on manually. A 
red light is used to indicate where the laser is released on the sheet. 
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Button Description 

 

Click to open the laser valve regularly. The system open the laser valve at the same 
time, and automatically close after continue the set jog parameter. 

 
Click to open the blow valve, click again to close, the blown gas is selected by  . 
When machining starts, the button is highlighted, and the system automatically opens 
the blow valve. 

 

Click to select the type of blowing gas, you can choose air, oxygen, nitrogen. 

 

Click to open the fan power, and then click to close. The manufacturer parameters 
under the set External Device Control - Exhaust category control whether to auto turn 
on or off the fan at the begin and end of machining. 

 

Turn on lubrication. 

 

Click to perform automatic exchange worktables to improve machining efficiency. 

 

By default, after open the software, the lamp button auto press and after OFF the 
software, the lamp button auto OFF. Also can manually control the lamp switch through 
the lamp button. 

2.4 Layer Toolbar 
Perform layer related operation. 

Include the following parts: 

 : Set the layer. For details, please see Layer Technic. 

 : Set the selected graphic machining. 

 : Set the selected graphic not to be machined, and the graphic will be white at 
this time. 

 : Change the color of the selected object to the color of 
the corresponding layer. 

2.5 Machining Information Statistics Column 
The machining information statistics column is as follows: 

 
Can do the following: 

 Click Report to view the Report. 

 Click Count Setting to set Count Setting. 
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 View the current total machining time, remaining time for re-machining (when cycle 
machining is enabled), system status, machining speed, current layer and 
machining count. 

2.6 Alarm/System Information Bar 
The alarm/system information bar is as follows: 

 
Can do the following: 

 Double click Alarm/System, Log. 

 Double click corresponding to the alarm item or system information item, and view 
the time, cause and solution of the alarm or log details in the pop-up dialog box. 

2.7 Drawing Information Bar 
The drawing information bar is as follows: 

 
Can do the following: 

 View and set the scale factor of the drawing area. 

 View and set the single movement distance of the graphic in the drawing area. 

Example: Set the jiggle distance to 10mm, select the graphic and press the → key on the keyboard, 

and the graphic will move 10 mm to the right. 

 View related steps and prompt information for drawing graphic and perform 
machining operation. 

2.8 Drawing Area 
Used to preview and draw graphic in this area. 

The type of graphic type drawn include: 

 

2.9 Drawing Toolbar 
Can do the following: 

 Graphic Drawing 

 Support Auxiliary Tool 
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3 Coordinate System 
The machine origin, also known as the machine tool origin, is the origin of the machine 
coordinate system. Its position is generally set at the lower left/lower right position of the 
machine tool. It is a physical position set by the machine tool manufacturer on the machine 
tool. Its function is to keep the actual machine coordinate origin of the machine tool 
consistent with the machine coordinate origin read on the software, and establish the start 
point for measuring the machine tool motion coordinate. Every time the CNC machine tool 
is started, the machine origin zero return operation must first be performed so that the 
CNC machine tool and the control system can establish a coordinate relationship and the 
control system can activate the soft limit function of each axis. 

In the cutting software, taking the lower right corner as an example, the figure below 
shows the machine origin position displayed on the software. 

 

3.1 Machine Origin 

3.1.1 Definition 
The machine origin, also known as the machine tool origin, is the origin of the machine 
coordinate system. Its position is generally set at the lower left/lower right position of the 
machine tool. It is a physical position set by the machine tool manufacturer on the machine 
tool. Its function is to synchronize the CNC machine tool with the control system and 
establish the start point for measuring the motion coordinate of the machine tool. Every 
time the CNC machine tool is started, the machine origin zero return operation must first 
be performed so that the CNC machine tool and the control system can establish a 
coordinate relationship and the control system can activate the soft limit function of each 
axis. 

In the cutting software, taking the lower right corner as an example, the figure below 
shows the machine origin position displayed on the software. 
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After the software successfully execute the machine origin zero return action, there will be 

an origin  mark (BMW mark) in the coordinate display column. 

 
There are two ways to set the machine origin return: 

 Datum setting 

 Machine zero return 

3.1.2 Datum Setting 
It is only applicable to absolute encoder machine tool. Using this method, there is no need 
to install a fixed origin signal on the machine tool. 

Prerequisite: 

Before use, make sure the parameter Absolute Encoder Back Home(X) is set to 1. 

 
Operation Steps: 

1. Move cutting head to desired origin position. 

2. In the menu bar, click Machining → Set Datum and select the corresponding sub-

menu to perform datum setting to set the current position as the machine origin 
position (datum point). 
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3.1.3 Machine Zero Return 
It is suitable for incremental encoder machine tool and absolute encoder machine tool. 
When using this method to return to the mechanical origin, the machine tool must be 
equipped with a mechanical origin signal. 

Prerequisite: 

If it is an absolute encoder machine tool, before using this zero return method, the 
parameter Absolute Encoder Back Home(X) need to be set to 0. 

Operation Steps: 

If there is no BMW logo after opening the software, you can click Machining → Set Datum 

on the menu bar to select the corresponding axis to perform the return to machine origin 
operation. 

 
Or operate on the machine tool control bar: 

 All Return to Machine Origin: Click  Go Home to automatically return to 
the machine origin in the order of the Z-axis first, and then the X, Y, and W axes. 
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 Only Z-axis Return to Machine Origin: Click . 
Related Instructions: 

The machine zero return method is divided into three steps: coarse positioning stage, fine 
positioning stage, and retract stage. 

 Coarse Positioning Stage: Find the origin switch according to the parameter 
coarse positioning stage direction and coarse positioning stage speed. After finding 
the origin switch, latch the coarse positioning stage axis feedback position; 

 Fine Positioning Stage: After the coarse positioning stage end, the fine positioning 
stage enter. Reversely search for the Z-phase signal according to the parameter 
fine positioning stage speed. After searching for the Z-phase signal, latch fine 
positioning stage axis feedback position; 
If the Z-phase signal is not enabled for the corresponding axis, the signal detected 
by the fine positioning stage is still the machine origin signal. 

 Retract Stage: After the fine positioning stage is completed, retract to the target 
position according to the set retract distance and retract speed. It should be noted 
that when the retract distance parameter is positive, the retract direction is 
consistent with the coarse positioning direction. When the retract direction is 
negative, the retract direction and the coarse positioning direction are opposite. 
After retract is completed, the machine coordinate and feedback coordinate are set 
to 0, and there is a zero return mark in front of the corresponding axis. 
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3.2 Workpiece Zero Point 

3.2.1 Definition 
The workpiece zero point refer to the reference point used to determine the workpiece 
position and coordinate in machining. It is the start point during the machining process. 

In the cutting software, the intersection point of the two green coordinate lines in the 
coordinate system is the workpiece zero point, and the workpiece coordinate of the XY 
axis corresponding to the workpiece zero point is 0. 

  

3.2.2 Set Workpiece Origin 
The zero point of each axis in the tool path is the workpiece origin. Before machining, 
confirm the actual position of the workpiece origin on the plate. 

Operation Steps: 

Choose any of the following methods to execute: 

 In the Drawing interface, drag the mouse to the cross mark at the intersection of 
the horizontal ruler and the vertical ruler to the target position. 

 
 In the machine tool control bar, specify the laser head position as the workpiece 

origin: 
a. Manually jog or step to move the cutting head to the target position. 

b. Click  to set the current position as the workpiece origin. 

 Manually set the workpiece origin: 

a. In the function menu bar, click  , and the cursor changes to . 
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b. Left click to select the workpiece origin position. 
c. Right click to exit the picking tool. 

 Specify the coordinate of the laser head X-axis/Y-axis as the workpiece origin: 

a. In the menu bar, click Machining → Work Coordinate. 

b. Select coordinate system, set X/Y axis coordinate, or select historical 
workpiece origin. 

 
c. Click Confirm. That is, the selected workpiece zero point is applied. 

3.2.3 Auto Clear Workpiece Coordinate 
To facilitate machining, you can set Auto Clear Workcoor to Yes in the system 
parameters. In this way, before machining start, directly move the cutting head to the 
desired workpiece zero point position, click Frame or Machining directly, and the current 
position will auto set to the workpiece zero point. 

 
When the system parameter Auto Clear Workcoor is set to No, manual workpiece to zero 
is needed. 

 
Manual workpiece to zero method: First move the cutting head to a suitable position on the 
plate (generally recommended in the lower left corner), and then click the Set Origin 
button. 
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At this time, the workpiece coordinate of the XY axis return to 0, and the workpiece zero 
coordinate datum on the software will move to the cross cursor position. 

 
3.2.4 Workpiece Zero Return 
Operation Steps: 

 Manual control: In the machine tool control bar, click   and the cutting head 
will move to the workpiece zero position. 

 After machining, auto return to the workpiece origin: 

Click System → System Parameters in the menu bar and set the value of the 

parameter Additional Behavior of XY Axes after Machining to 10. 

 

3.3 Berth Point 

3.3.1 Definition 
The berth point is the position of the cutting figure berth at the origin of the workpiece with 
the outer frame of the cutting figure set as datum. As shown below, the lower left corner of 
the outer frame of the graphic is set as the workpiece zero point, and the berth point is the 
workpiece zero point position when the berth point is the upper left/middle left/lower left: 
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3.3.2 Set Berth Point 
Operation Steps: 

1. In the common toolbar, click  Berth, and pop-up the Set Berth Point 
dialog box:  

 
2. Select berth position. 
3. Check Exclude Unprocessed Graphics as needed. 

o If checked, when performing workpiece to zero on a tool path with not 
machining primitive, the outer frame of the machining primitive will be used to 
perform workpiece to zero. 

o If not checked, then when performing workpiece to zero on a tool path with 
not machining primitive, the outer frame of the whole tool path will be used to 
perform workpiece to zero. 

4. Check Computational Graphics Process as needed. 
This function is mainly targeted at lead line technic. 

o If checked, the estimated graphic outer frame when the workpiece is set to 
zero will include the lead line, as shown below: 
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o If not checked, the workpiece to zero will recognize the lead line outside the 
graphic frame, as shown below: 

 
 

Note: When using not checked apply layer technic, there is a risk of cutting out the 
plate during cutting machining. 

5. Click Confirm. 

3.3.3 Auto Apply Berth Point 
Auto apply berth point, when the workpiece to zero, the cutting graphic auto berth at the 
set berth point position. 

In the common toolbar, click the  drop-down key and check Auto Apply Berth 
Point. 

3.4 Mark Point 

3.4.1 Definition 
Mark point is a representative fixed point on the machine tool that is set according to the 
customer's habits (based on machine coordinate). When using mark point, multiple fixed 
points can be marked on the machine tool. Customers can use it as a safe position for XY 
return after machining, different workpiece origin positions in multiple workpiece coordinate 
systems, etc. 

In the cutting software, 8 mark points are provided, and different colors are used to 
distinguish different mark points. 

 
3.4.2 Set Mark Point 
Operation Steps: 

1. Select any of the following methods to open the Mark Point dialog box: 

o In the drawing toolbar, click  Mark Point. 

o In the menu bar, click Machining → Mark Point. 
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2. Select mark point n in the Mark Point n drop-down box. The value range of n is: 

1~8. 
3. Select any of the following methods to set the X and Y coordinate value. 

o In the machine tool control bar, click the X-axis and Y-axis direction buttons, 
move the cutting head to the target position, and click Mark. 

o If the target position is not a marked point and need quick positioning to the 
specified machine coordinate position, check Quick Position, enter the X 
coordinate value and Y coordinate value, click Locate, move the cutting 
head to the specified position, and click Mark. 

4. Optional: In the Mark Point dialog box, you can also do the following: 
o Click To Mark Point, and the cutting head auto return to the mark point 

position. 
o If you need all marked points to be displayed in the drawing area, click Show 

All. 

3.4.3 To Mark Point 
Return the cutting head to the corresponding mark position. 

Operation Steps: 

 Manual control: 
a. Select any of the following methods to open the Mark Point dialog box: 

 In the drawing toolbar, click  Mark Point. 

 In the menu bar, click Machining → Mark Point. 

 
b. Select mark point n in the Mark Point n drop-down box. The value range of 

n is: 1~8. 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 22 / 161 

c. Click To Mark Point, and the cutting head will auto return to the Mark Point 
n position. 

 Auto return to fixed point after machining: 

Click System → System Parameters in the menu bar and set the value of the 

parameter Additional Behavior of XY Axes after Machining to 1 - 8. 

 

3.5 Fixed Point 

3.5.1 Definition 
The fixed point is a fixed point set on the software based on the machine coordinate. After 
machining, you can choose to move the cutting head return to the fixed point position. 

3.5.2 Set Fixed Point 
Operation Steps: 

1. In the menu bar, click System → System Parameters, select the node Overview → 

Advanced Function → 4.2 Fixed Point, right display the parameter and parameter 

information of the fixed point. 
2. Double click Fixed Point Position (X) or Fixed Point Position (Y) to set the target 

position value of the parameter. 

 
3.5.3 To Fixed Point 
Operation Steps: 

 Manual control: 

In the menu bar, click Machining → To Fixed Point, and the cutting head auto 

return to the fixed point position. 

 Auto return to fixed point after machining: 

Click System → System Parameters in the menu bar and set the parameter 

Additional Behavior of XY Axes after Machining to 9. 
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3.6 FAQ 

3.6.1 Why “Return to Machine Origin before Machining”? 
Answer: It is recommended that the parameter "return to machine origin before machining" 
is set to "Yes". Not returning to the machine origin is not allowed for machine tool auto 
running. 

Since the servo system use an incremental encoder, the system can only know its current 
position relative to its previous position. In order to make any position on the machine tool 
as a fixed coordinate, need select a reference point, which is the machine origin. The 
reason for return to machine origin before machining is: 

1. To prevent deviation, combine it with breakpoint resume. Because the machine tool is 
powered off during machining or E-stop occur, the motor enter the free status after power 
off. When restarting the machine tool to resume machining, it will be offset. After returning 
to the machine origin, the offset machine coordinate system can be corrected back to 
more accurately retrieve the original workpiece zero point, and then perform breakpoint 
resume to ensure the accuracy of resume machining; 

2. Establish the coordinate system of the machine origin. Especially for machine tool with 
automated nozzle function, because the mechanical coordinate position of each nozzle 
base in the nozzle library is fixed. 

3.6.2 What are "Coarse Positioning" and "Fine Positioning"? 
Answer: These two parameters are the parameters for returning to the machine origin, and 
they are effective when returning to the machine origin. 

"Coarse positioning" refer to the process in which the machine tool spindle return to the 
machine origin from any position, and the spindle travel from this point to the time when 
the origin switch receive a signal. 

"Fine positioning" means that after the machine tool get the origin signal, it slowly move in 
the "fine positioning direction" at the "fine positioning stage speed". After getting the 
encoder zero signal (if the Z-phase signal of the corresponding axis is not enabled, the 
fine positioning stage also get the machine origin signal), the return to the machine origin 
is completed, and then the machine tool retract a "retract distance". 

3.6.3 What is the Use of "Retract Distance"? 
Answer: "Retract" means that after returning to the machine origin, the machine tool will 
retract a certain distance and leave the signal sensitive area of the origin switch. 
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4 Quick Start 
4.1 Overview 
Through this part, you can quickly know the sheet machining process of NcStudio-V15 
Laser Cutting Control System and control the machine tool to perform laser cutting on 
the sheet metal. 

The process is as follows: 

 

4.2 Machine Origin Zero Return 
There are two ways to set the machine origin zero return: 

 Datum setting: Only applicable to absolute encoder machine tool. Using this method, 
there is no need to install a fixed origin signal on the machine tool. For details, 
please see Datum Setting. 

 Machine zero return: Suitable for incremental and absolute encoder machine tool. 
When using this method to return to the machine origin, the machine tool must be 
equipped with machine origin signal. For details, please see Machine Zero Return. 

4.3 Calibrate Cutting Head 
Measure the corresponding relationship of the capacitance with position between the 
cutting head and the plate to control the Z-axis floating up and down in real time to ensure 
that the relative distance between the cutting head and the plate remains unchanged in 
the follow-up state. 

Operation Steps: 

1. Select the following methods to open the Follow dialog box: 

o In the common toolbar, click . 
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o In the menu bar, click Advanced → Follow Control. 

 

2. Click  Servo Calibration to perform servo calibration to solve the servo motor 
zero point drift problem caused by speed loop control. 
At this time, the cutting head move back and forth in a small amount for servo 
compensation. 

3. Select the following methods to calibrate the cutting head: 
o If the cutting head has not been calibrated, click the Z-axis direction button, 

move the cutting head to about 5mm close to the board surface, and keep 

the board surface still. Click  Calibrate to calibrate the cutting head. 

o If the cutting head has been calibrated, click  One Key Calibrate. 
The system auto execute calibrate, which take about 20 seconds to complete. 

After the cutting head is calibrated, in the Calibration Data area, check whether the 
Stability and Smooth are higher than Good. If they are lower than Good, recalibrate. 

4.4 Load or Draw Graphic 
Before machining, it is necessary to load the tool path or draw graphic. 

Select the following methods to load or draw graphic: 

 Select the following method to load graphic: 
o Drag the G, NC DXF, DWG, PLT, NCEX, LXD, and CNC format files to be 

loaded into the software drawing area. 
o Open NCEX format file: 

 In the common toolbar, click  Open. 

 In the menu bar, click File → Open. 

o Select the following methods to import files: 
 If need to import G, NC, DXF, DWG, PLT, LXD, CNC format files, click 

 Import on the common toolbar. 
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If need to import G, NC format files, please note: 

 Import Standard G Code: Before importing, it need to be 
modified according to the G code specifications provided by our 
company. Please contact our company for details. 
After importing, if need to adjust or switch view, right click. 

 Only Import CAD Information in G Code: Import the CAD 
information of the tool path file. 

After importing and running, the tool path auto generate an NCEX format file 
and store it in the NceFiles folder on the desktop. If there is no this folder, the 
system will create it by itself. 

If need to insert G, NC DXF, DWG, PLT, NCEX, LXD, CNC format files based on 

the original tool path file without overwrite the original tool path, click File → Insert 

in the menu bar. 

 Select the following method to draw graphic: 
o Manual Drawing. 
o Use graphics Gallery. 

After loading or drawing the graphic, do the following: 

 Edit Graphic 

After editing the graphic, you can click File → Export File to export the current 

graphic as DXF or DWG file so that the tool path can be used multiple times. 

 Graphics Pre-process. 

 Set Machining Technic. 

 Set Layer Technic. 
After performing the above operations, select the following method to save the file: 

 If need to save the whole tool path, click File → Save / Save As in the menu bar, or 

click  Save in the common toolbar. 

 If need to save the selected graphics in the tool path, click File → Save Selected 
As in the menu bar, select the save path and click Save. 

4.5 Set Workpiece Origin 
The zero point of each axis in the tool path is the workpiece origin. Before machining, 
confirm the actual position of the workpiece origin on the plate. For details, please see 
Workpiece Zero Point. 

4.6 Edge Finding Positioning 
If the plate is placed arbitrarily on the workbench, the long and wide edges of the plate will 
not be parallel to the X and Y axis of the machine tool. If machined directly, excess 
residual material will appear and the plate will be wasted. The purpose of edge finding is to 
obtain the angle between the long or wide edge of the plate relative to the machine tool 
axis. During machining, the machined workpiece coordinate system is rotated to the same 
angle as the edge finding, so that the machined workpiece coordinate system is parallel to 
the plate long or wide edge. This avoid plate cutting waste caused by the plate place and 
the machine tool axis not being parallel. 
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Function entry: 

 In the machine tool control bar, click  to open the Edge Finding dialog box. 

 In the drawing tool control bar, click  to open the Edge Finding dialog box. 
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4.6.1 Edge Finding Method 
The software support the following edge finding methods. Need to confirm the plate size 
and select the correct edge finding method: 

 Auto edge finding 
Use the follow-up mode auto find the plate edge position, and obtain the plate edge 
finding data according to the movement sequence planned by the software. 

 Manual edge finding 
Manually move the cutting head, use red light to find the edge position and record it, 
and then calculate the edge finding result. 

4.6.2 Auto Edge Finding 
The auto edge finding function usage step mainly include: 

1. Set auto edge finding parameter. 
2. Apply auto edge finding. 

According to different sheets, the software provide the following auto edge finding 
positioning methods: 

 3-Point: Applicable to normal sheet. 

 Sheet: It is suitable for thin plate with thickness of less than 10mm. The three-point 
edge finding is expanded to six-point edge finding to improve the problem of 
inaccurate edge finding result caused by uneven plates. 

4.6.2.1 Set Auto Edge Finding Parameter 
The origin O’ of the new workpiece coordinate system is the berth point position, and the 
out margin direction of the auto edge finding is the adjacent two sides of the berth position. 

The corresponding relationship between the berth position and the out margin direction is 
as follows: 

Berth 
Position 

X 
Direction 

Y 
Direction 

Lower right Positive Negative 

Upper right Positive Positive 

Lower left Negative Negative 

Upper left Negative Positive 

Before setting auto edge finding, make sure the berth point is at the upper right / lower 
right / upper left / lower left. 
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4.6.2.1.1 Auto Three-point 

 
Operation Steps: 

1. Set the auto three-point edge finding parameter. 
a. In the Edge Finding dialog box, set the edge finding method to Auto and the 

positioning method to Three-point. 
b. Set sheet size, offset parameter, finding speed and follow height. 
c. According to the usage habits, set the zero return after edge search and 

clear the edge finding data. 
2. Edge finding test. 

a. Click Start in the machine motion area in the Edge Finding dialog box to 
check whether the edge finding action will out margin in advance and 
whether the follow-up motion is normal. Check the test edge finding result in 
the finding result area. 

 
b. After the edge finding test is completed, click OK to save the setting. The 

edge finding result will appear in the drawing area. 
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c. At this time, click Frame to check whether the drawing boundary exceed the 

sheet. 

4.6.2.1.2 Auto Sheet 

 
The auto sheet edge finding setting operation is the same as the auto three-point edge 
finding, with additional need to set the Rack Clearance and Back Distance. 

 Rack Clearance: Set according to the distance between machine tool racks. 

 Back Distance: In order to return the distance within the sheet after edge finding, if 
the sheet tilt is serious during edge finding, the retract distance can be appropriately 
increased to avoid start edge finding from outside the sheet when the same edge is 
found multiple times. 

4.6.2.2 Apply Auto Edge Finding 

4.6.2.2.1 Auto Edge Finding before Machining 
Operation Steps: 

1. In the Edge Finding dialog box, click in the lower left corner Enable Edge Finding 

function to the ON status. At this time, the in the machine tool control bar  
become light, and click OK. 
After the enable edge finding function takes effect, the tilt degree will be displayed 
in the upper left corner of the software and the zero point position of the workpiece 
will be automatically adjusted. 

 
2. In the Edge Finding dialog box, check Find Edge Before Start. 
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3. (Optional:) If need to set a fixed start point for edge finding, in the Edge Finding 
dialog box, click Fixed Point to set the XY coordinates of the edge finding start 
point. 

 
4. Set zero return after edge finding according to usage habits. This is also common 

with the Return to O’ after Edge Finding parameter in the Edge Finding dialog 
box. 

5. In the Edge Finding dialog box, click OK. 

Before actual machining, you can first turn on the red light and press the Edge Seek 
button on the handle to check whether the machining tool path will exceed the machining 
range and check whether the red light will exceed the sheet edge. 

Also can directly click Start to start machining, and auto edge finding will be performed 
before machining. 

4.6.2.2.2 Use Custom Angle 
There is an option Always Use Custom Angle in auto three-point and sheet edge finding. 
In special cases, such as a fixed deviation of the sheet, you can enable the custom angle 
without using the auto edge finding function to improve machining efficiency. 

Operation Steps: 

1. In the Edge Finding dialog box, click in the lower left corner Enable Edge Finding 

function to the ON status. At this time, the in the machine tool control bar  
become light, and click OK. 

2. Check Always Use Custom Angle and fill in the custom angle in the finding result. 
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3. Click OK to save the settings. During actual machining, the software will not 
perform edge finding, but will directly offset according to the custom angle. 

4.6.2.3 Parameter Meaning 
Auto edge finding parameter description: 

Name Description 

Offset distance It is used to leave enough allowance for the sheet edge. After edge finding is 
completed, when the workpiece zero point is determined, an offset will be generated 
based on the offset distance. When set to positive value, the zero point is offset 
toward the inside of the sheet, and when it is set to negative value, the zero point is 
offset toward the outside of the sheet. 

The origin obtained by edge finding is exactly at the sheet edge. Offset 0 will cause 
machining to the sheet edge position, and the sheet will be seriously warped, so 
generally it is necessary to leave a certain space for the sheet edge. 

Setting it to positive value can leave a certain allowance for the sheet edge, and 
negative value is used for specially shape sheet. 

 Range: -100mm-100mm 

Finding speed The cutting head move speed when perform edge finding action. Too fast speed 
may affect the edge finding accuracy. The recommended value is around 
6000mm/min. 

 Range: 3000 mm/min -15000mm/min 

Follow height Follow-up height during edge finding. Too high may affect edge finding accuracy. 
The recommended value is 1mm. 

 Range: 0.1mm-16mm 

Clear edge 
finding data 
after machining 

It is mainly used for a single edge finding in flexible machining. After enable, the 
current edge finding data will auto cleared when the machining is completed. 

Return to O’ 
after edge 
finding 

After the edge finding is completed, it return to the new workpiece zero point, which 
is convenient for the workpiece to zero and start machining directly. 

Always use 
custom angle 

After enable, the original edge finding function will be invalid and the custom angle 
will always be used for machining. 

Set the custom angle by checking custom angle on the right. 

Rack clearance It is used during auto sheet edge finding. In order to avoid the influence of the rack, 
on the basis of the original 3-point edge finding, edge finding will be performed again 
at interval of one rack clearance length. It need to be set according to the actual rack 
clearance of the machine tool. 

Range: 1mm-200mm 

Back distance The distance within the back sheet after edge finding during auto sheet edge finding. 

 Range: 30mm-40mm 

4.6.3 Manual Edge Finding 
According to different sheets, the software provide the following manual edge finding 
positioning methods: 

 2-point: Suitable for coil material, only perform edge finding on one edge. Only 
provide in software that support coil material cutting. 

 3-point: Suitable for general sheet. 
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Prerequisite: 

Before using manual edge finding, make sure you have clicked on  pos laser to turn 
on the pos laser guide position. 

4.6.3.1 Manual 2-point 
Manual 2-point edge finding needs to obtain the 2-point position on one edge and then 
calculate the sharp corner position and tilt degree of the sheet. 

 
Operation Steps: 

1. In the Edge Finding dialog box, set the edge finding method to Manual and the 
positioning method to 2-point. 

2. Set the edge finding direction. 2-point edge finding only perform edge finding on 
one edge, and you can select the edge finding direction: 

o X direction 
o Y direction 
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3. Set the O point position. The workpiece zero point position, a new workpiece zero 
point O’ will be automatically generated after edge finding. 

 
4. Set A point and O’ point. According to the prompt in the schematic diagram, 

manually move the cutting head to the corresponding position of the sheet, click to 
Set A to take the A point, and click to Set O’ to take the O’ point. 

 
The software automatically connects the two points A and O’ to determine the new 
X-axis. Draw a straight line perpendicular to O’A through point O’ to determine the 
new Y-axis to form a new workpiece coordinate system. 
If need to restore the current coordinate to the software default value, click Reset 
O’A to re-select. 

5. Click Calculate and check the automatically calculated positioning results in the 
finding result area. 

 
If the rotation angle is greater than 15°, it indicate that the sheet is too offset and 
the sheet need to be replaced and edge finding positioning need to be performed. 
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6. Click in the lower left corner Enable Edge Finding function to the ON status. Click 
OK. If you can see the tilt angle in the upper left corner of the software, the setting 
is successful. 

 
4.6.3.2 Manual 3-point 
Manual 3-point edge finding need to obtain two points in the X direction, and then obtain a 
point in the Y direction to calculate the sharp corner position and tilt degree of the sheet. 

 
Operation Steps: 

1. In the Edge Finding dialog box, set the edge finding method to Manual and the 
positioning method to 3-point. 

2. Set the O point position. The workpiece zero point position, a new workpiece zero 
point O’ will be automatically generated after edge finding. 

 
3. Follow the following step to manually find A, B, and C points to determine the new 

workpiece coordinate system: 
According to the schematic prompt, manually move the cutting head to the position 
corresponding to the sheet, taking the O point position as the lower left as an 
example: 
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a. Manually move the cutting head to the boundary in the positive direction of 
the X-axis of the sheet, click Set A and Set B to take A and B two points. 
When taking the point, A point X-axis coordinate need smaller than point B. 
The software auto connect the A and B two points to determine the new X-
axis. 

b. Manually move the cutting head to the boundary of the Y-axis positive 
direction of the sheet, click Set C to take C point. 
The software auto determine the straight line pass through C point and 
perpendicular to AB as the new Y-axis. 

If need to restore the current coordinate to the software default value, click Reset 
ABC and select again. 

4. Click Calculate and check the auto calculated positioning result in the finding result 
area. 

 
If the rotation angle is greater than 15°, it indicate that the sheet is offset too much 
and the sheet need to be repositioned before edge finding positioning. 

5. Click in the lower left corner Enable Edge Finding function to the ON status. Click 
OK. If you can see the tilt angle in the upper left corner of the software, the setting 
is successful. 

 
4.6.4 Edge Finding Action Process 

4.6.4.1 2-point 
1. Positioning A’ point: 

a. Enable follow-up at position A. 
b. Move in the X negative direction at Finding Speed, and set the out margin 

as A’ point. 
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2. Positioning B’ point: 

a. Move to B position and enable follow-up. 
b. Move in the X negative direction at Finding Speed, and set the out margin 

as B’ point. 

 
4.6.4.2 3-point and Sheet 
The sheet action process is steps 1 ~ 6, and the normal sheet action process is steps 1, 3, 
5. 

1. Positioning C point: 
a. Enable follow-up at the current position. 
b. Move to the short side at Finding Speed, and set the out margin as C point. 

2. Positioning C' point: 

 
a. From C point, according to the value of Retract Distance and Rack 

Clearance, the X-axis and Y-axis linked retract into the sheet to the retract 
point. 

b. Move to the short side at Finding Speed, and set the out margin as C'. 
3. Positioning A point: 

a. Position it 20% from the short side boundary and enable follow-up. 
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b. Move in the long side direction, and the out margin is designated as A point. 
4. Positioning A' point: 

 
a. From A point, according to the value of Retract Distance and Rack 

Clearance, the X-axis and Y-axis linked retract into the sheet to the retract 
point. 

b. Move to the long side at Finding Speed, and set the out margin as A' point. 
5. Positioning B point: 

a. Position it 20% from the other edge of the short side and enable follow-up. 
b. Move in the long side direction at Finding Speed, and set the out margin as 

B point. 
6. Positioning B' point: 

 
a. From B point, according to the value of Retract Distance and Rack 

Clearance, the X-axis and Y-axis linked retract into the sheet to the retract 
point. 

b. Move to the long side at Finding Speed, and set the out margin as B' point. 

4.6.5 Historical Edge Finding Angle 
Through historical information, you can find the historical workpiece origin, historical edge 
finding angle and historical calibration result. This function is often used in the auto clear 
workpiece coordinate mode. When the user perform certain specific operations (cutting 
frame, dry run, restart machining), the original workpiece origin will auto clear, resulting in 
original origin position loss. 

Operation Steps: 

1. In the menu bar, click System → History Information to pop-up the History 

Information dialog box: 
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4.6.6 FAQ 

4.6.6.1 Find Cutting Position not on the Tool Path after Pause during Machining 
Answer: What is shown in machining is the drawing compared to the workpiece zero point 
offset. It is convenient to observe the machining trajectory. After pausing during machining, 
the machine coordinate without offset will be displayed. It seem that they are not on the 
machining trajectory and will not affect machining. 

4.6.6.2 Whether to use Edge Finding Angle for One Key Cutting Sheet? 
Answer: Yes, but it must be enabled in the system setting. After enable it, you can 
manually execute it once when you need to edge finding angle for single cutting sheet. 
When used in batch machining, the data obtained by auto use auto edge finding. 

4.7 Simulation 
Before machining, you can use simulation to check whether the machining range and tool 
path travel range are reasonable, and check the machining path. 

Simulation is divided into: 

 Simulation: It does not control the machine tool to perform corresponding machine 
electrical action. It only display the machining path at high-speed in the object edit 
area, which is used to directly observe the problem encountered during the 
machining process and make adjustment. It does not actually occupy and consume 
resources such as machine tools and workpieces. 

 Cutting Frame: Control the machine tool to travel along the rectangular frame 
outside the machining file, which is used to determine the machining range. 

 Dry Run: Control the machine tool to run the program with disable the laser and 
machining related port, and check whether the machining trajectory is correct. 

Select the following methods to perform simulation: 

 Simulation 
Note: Before simulation, ensure that the current system status is Idle. 

o In the machine tool control bar, click . 

o In the menu bar, click Machining → Mach Control → Simu. 
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o In keyboard, press F8. 
The machine tool auto start high-speed simulation machining from the first stage of 
the simulation program. 

 Cut Frame 

o In the machine tool control bar, click . 

o In the menu bar, click Machining → Mach Control → Cut Frame. 

 Dry Run 

o In the machine tool control bar, click . 

o In the menu bar, click Machining → Mach Control → Dry Run. 

4.8 Start Machining 
The formal machining link controls the start of machining. 

Before start machining, make sure there are no E-stop or other alarms. 

 Start machining 
After determining the workpiece zero point and drawing technic, select any of the 

following methods to start machining. ①Open Shutter,②Press Start and the 

cutting machine will follow light cutting according to the cutting path. 

o In the machine tool control bar, click  , then click . 

o In the machine tool control bar, click  , and then in the menu bar, click 

Machining → Mach Control → Start. 

After start machining, the following operations can be performed: 

 Stop machining 
Make the machine tool stop machining and stop the whole machining task, and the 
system enters Idle status: 

o In the machine tool control bar, click . 

o In the menu bar, click Machining → Mach Control → Stop. 

 Breakpoint resume 
If there is stop during the cutting process, you can directly click Resume. After 
clicking, the cutting machine will retreat from the stopped position one Back 
Distance when Breakpoint Continues to continue cutting. (Parameter position: 

System → System Parameters → Advanced Function → 4.3 Resume) 

o In the machine tool control bar, click . 

o In the menu bar, click Machining → Mach Control → Resume. 

 Breakpoint location 
Before breakpoint resume, you can execute Locate first. After executing breakpoint 
locate, it will return to the resume cutting position according to Back Distance 
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when Breakpoint Continues. You can observe whether the retract distance is as 
expected. If it is not as expected, you can use the Fwd and Bwd buttons to move 
the position of the cutting head to adjust the breakpoint start position. After 
executing any one or several actions in Locate / Fwd / Bwd, and then execute 
Resume, the cutting head will no longer execute retreat, but resume cutting directly 
from the current position. 

Note: Machining flay cutting/high-speed micro-joint tool path. When breakpoint 
resume, it will auto retract to the previous micro-joint point or fly cutting intersection 
point. 

o In the machine tool control bar, click . 

o In the menu bar, click Machining → Mach Control → Locate. 

 Machining nest tool path 
After loading the tool path or using the cutting software nest, the nest result may 
have multiple nest result tool paths. The corresponding machining quantity can be 
set in the nest result, and the machining quantity can be changed in the nest result. 
When the part quantity is used up, the quantity cannot be increased. 

 
When machining the nest tool path, only the currently selected shape will be 
machined, and it will not jump even if the nest quantity is machined. If need jump, 

you can set parameter Auto Step to Next Zone in System → System Parameters 

→ Advanced Function → Habitual Setting → General to Yes. Prevent the 

inconsistency between machined nest quantity and setting. 
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5 Graphic Operation 
5.1 Drawing 
The drawing tools and operations that can be used in the drawing area, and the drawn 
graphics are used for machining. 

Drawing tools include: 

Tool Name Tool Name 

 
Dot 

 
Polyline 

 
Line 

 
Elliptic Arc 

 
Arc 

 
Ellipse 

 
Circle 

 
Polygon 

 
Star 

 
Rectangle 

 
Rounded 
Rectangle  

Runway 
Graphics 

 
Text 

 
Gallery 

After using the drawing tool, right click or press the Esc key to exit the tool. 

If you need to adjust the drawn graphic later, select the object and the following methods 
to modify: 

 In the common toolbar, to modify the size and position parameter. 

 Press Shift key and drag the rectangle points around the graphic to manually adjust 
the size. 

5.1.1 Polyline 
A polyline is a chain of lines and arcs that are joined together into one object. This system 
supports switching drawing of line and arc. 

Operation Steps: 

1. Select from the following methods to use Polyline: 

o In the drawing toolbar, click  Polyline. 
o In the menu bar, click Drawing → Polyline. 

2. Left click to select two points to draw a line. 
3. Optional: To switch to the arc mode, right click on the drawing window and select 

Tangent Arc. 
The arc is tangent to the last line/arc. 
If you need to switch back to line drawing mode, right click to call the shortcut menu 
and click Line. 

4. Left click to select another point. 
5. Right click and do one of the following: 

o Click Confirm to confirm that the current point is the end point of the polyline, 
and this polyline is an unclosed shape. 

o Click Close to connect the current point and the start point with a line, and 
this polyline is a closed shape. 
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o Click Cancel to cancel all previous point selection operations and exit 
polyline drawing. 

After drawing a polyline, to change an unclosed polyline into a closed one, select it and 
check Close in the common toolbar. This operation is irreversible. 

5.1.2 Elliptic Arc 
Operation Steps: 

1. Select the following methods to call Elliptic Arc: 

o In the drawing toolbar, click  Elliptic Arc. 
o In the menu bar, click Drawing → Elliptic Arc. 

2. Draw an ellipse. Check Ellipse. 
3. Left click to select the start and end point of the elliptic arc. 

System CCW generates an elliptic arc tool path. 

5.1.3 Arc 
Operation Steps: 

1. Select the following methods to call Arc: 

o In the drawing toolbar, click  Arc. 
o In the menu bar, click Drawing → Arc. 

2. Left click to select the center point. 
3. Left click to select a point. 

This point is the start point of the arc, and the distance from the center is the radius. 
4. Left click to select the end point of the arc. 

System CCW generates an arc tool path. 

5.1.4 Ellipse 
Operation Steps: 

1. Select the following methods to call Ellipse: 

o In the drawing toolbar, click  Ellipse. 
o In the menu bar, click Drawing → Ellipse. 

2. Left click to select the center point. 
3. Left click to select two points respectively. 

The distances between the two points and the center point are the major and minor 
axes of the ellipse, respectively. 

5.1.5 Circle 

5.1.5.1 Draw Circle by Radius 
Operation Steps: 

1. Select the following methods to call Draw Circle by Radius: 

o In the drawing toolbar, click  Circle. 
o In the menu bar, click Drawing → Circle → Draw Circle by Radius. 

2. Left click to select the center point. 
3. Left click to select a point. The distance between this point and the center point is 

the radius. 

5.1.5.2 Draw Circle by 3Point 
1. In the menu bar, click Drawing → Circle → Draw Circle by 3Point. 
2. Left click three times continuously to select three points to form a circle. 
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Note: The selected three points are not on a straight line and do not overlap, then 
the three points can form a triangle. Draw any two vertical centerlines will get the 
intersection point, which is the center of the circle. 

5.1.6 Polygon 
Operation Steps: 

1. Select the following methods to call Polygon: 

o In the drawing toolbar, click  Polygon. 
o In the menu bar, click Drawing → Polygon. 

2. Set parameter Edges in the common toolbar and press Enter. 
3. Left click to select the center point. 
4. Left click to select the vertex position. 

5.1.7 Star 
Operation Steps: 

1. Select the following methods to call Star: 

o In the drawing toolbar, click  Star. 
o In the menu bar, click Drawing → Star. 

2. Set parameter Vertexes in the common toolbar and press Enter. 
3. Left click to select the center point. 
4. Left click to select the vertex position. 

5.1.8 Rectangle 
Rectangular. 

Operation Steps: 

1. Select the following methods to call Rectangle: 

o In the drawing toolbar, click  Rectangle. 
o In the menu bar, click Drawing → Rectangle. 

2. Left click to select the start point. 
3. Set parameter Rotation in the common toolbar. Enter the angle to rotate around 

the start point and press Enter. 
4. Left click to select the end position. 

5.1.9 Rounded Rectangle 
A rectangle with rounded corners. 

Operation Steps: 

1. Select the following methods to call Rounded Rectangle and open Rounded 
Rectangle dialog box: 

o In the drawing toolbar, click  Rounded Rectangle. 
o In the menu bar, click Drawing → Rounded Rectangle. 
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2. Enter parameter, click OK. 
3. Left click to select the position. 

5.1.10 Runway Graphics 
Operation Steps: 

1. Select the following methods to call Runway Graphics and open Runway 
Graphics dialog box: 

o In the drawing toolbar, click  Runway Graphics. 
o In the menu bar, click Drawing → Runway Graphics. 

 
2. Enter parameter, click OK. 
3. Left click to select the position. 

5.1.11 Text 
It is mainly used to draw text in an advertisement board. 

Operation Steps: 

1. Select the following methods to call Text: 
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o In the drawing toolbar, click  Text. 
o In the menu bar, click Drawing → Text. 

2. Drag the cursor to define a rectangular text box. 
3. Enter text in the input box. 

Need switching when enter, press the Ctrl+Enter combination key. 
4. Press the Enter key to complete text drawing. 

5.1.12 Gallery 
The software come with commonly used standard graphic parts, and support users to call 
and modify graphic parameters. 

Operation Steps: 

1. Select the following methods to call Gallery: 

o In the drawing toolbar, click  Gallery. 
o In the menu bar, click Drawing → Gallery. 

2. In the Gallery dialog box, select the target graphic. Follow as the preview effect of 
the graphic. 

 
3. Double click the corresponding parameter in the parameter bar to set the parameter 

value. 
4. In the Path Position area, select one of the following methods to set the position of 

the graphic. 
o Check Fixed Position, set the value of X coordinate and Y coordinate, click 

OK. 
The values of the X and Y coordinates set are the red dot positions on the 
preview effect. 

o Check Set by Mouse, click OK to close the Gallery dialog box. In the 
Drawing Area, select a position and click the mouse. 

5.1.13 Cut-off Line 
Manually draw the cut-off line to achieve quick cut-off of the plate. 

Schematic diagram of cut-off line composition: 

The length of cut-ff line both ends extension line can be set separately. 
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Operation Steps: 

1. In the software main interface, draw the line that needs to be cut-off in the drawing 
area, and select the primitive. 
You can also draw multiple lines, select them all, and set them in batch. 

2. Set the length of the cut-off line extension line. 

Click Drawing→ Cutoff Line Setting on the menu bar, or right click and select 

Cutoff Line→ Cutoff Line Setting. 

 
3. Create cut-off line. 

In the menu bar, click Drawing → Create Cutoff Line, or right click to select Cutoff 

Line → Create Cutoff Line. 

If need to clear cut-off line, select Clear Cutoff Line. 

5.2 Select and View Operation 
View function is used for a better view of objects without changing the actual sizes and 
coordinates. 

5.2.1 Select Object 
The software provide many graphic select methods. 

 Manual Select: Select any object by yourself. 

 Auto Select: Auto select object that meet the conditions. 

5.2.1.1 Manual Select 
Operation Steps: 

1. In the drawing toolbar, click  Select Graph to call the manual select function. 
2. Select the following methods to select objects: 

o Left click to select a single object. 
o Press Ctrl key, then left click to select multiple objects. 
o Press and drag the left mouse button to frame the object from the upper left 

to the lower right, and select all graphics contained in the frame. 
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o Press and drag the left mouse button to frame the object from the lower right 
to the upper left, and select all graphics that intersect with the frame and 
included in the frame. 

5.2.1.2 Auto Select 
Operation Steps: 

In the drawing toolbar, click  Select Graph drop-down key or click Edit → Select in the 
menu bar to select the auto select method: 

  

 

 Select All: Select all graphics. 

 Select Invert: Select unselected graphics. 

 Clear Selected: No selection at all. 

 Select Unclosed: Select all unclosed graphics in the tool path file. 

 Select Tiny: In the pop-up dialog box, input the X, Y size range of the graphics to 
be selected, and the system will automatically select the graphics within the size 
range. 

 Select by Inner: Select the included graphics. 

 Select by Outer: Select the not included graphics. 
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 Select Similar: After manually selecting a graphic, click Select Similar, and the 
system will automatically select the graphic with the same type and size as the 
selected graphic. 
Note: This operation does not distinguish angles. 

 Select Similar (Strict in Angle): After manual select a graphic, click Select 
Similar(Strict in Angle), and the system will auto select the graphic with the same 
type and size as the selected graphic. 
Note: This operation distinguish angles. 

More advanced select operations: 

  

 Select by Layer: Select the corresponding layer in the submenu, and the system 
will auto select the graphics in this layer. 

 Select by Inner-outer: In the submenu, select the corresponding inner layer 
graphics (included graphics) or outer layer graphics (not included graphics). The 
system auto select the graphics corresponding to the nesting relationship, and the 
effect diagram is as follows: 

 
 Select by Type: Select the corresponding graphic type in the submenu, and the 

system will auto select the same type of graphic. 

5.2.2 Basic Operation 
Commonly used basic operations include: 

 Cut (Ctrl+X) 

 Copy (Ctrl+C) 
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 Datum copy (Shift+Ctrl+C): Select a point. The relationship between the graphics 
and the mouse position is the same as that of the datum and the original graphics 
when pasting. 

 Paste (Ctrl+V) 

 Paste as group: Copy two or more objects, select to paste as a group, then the 
selected objects will be combined into a group when pasted. 

 Delete 

 Clear clipboard 

 Clear selected: It can also be realized by click the blank area. 

 Forbid quick drag: After checking, it will not allow drag, copy, and rotate graphics to 
avoid misalignment of graphics due to misoperation. 

5.2.3 Pan View 
Repositioning the graphic in the window is convenient for observing different parts of the 
current graphic. 

Operation Steps: 

Select any of the following methods to pan view: 

 Press the mouse wheel and drag the mouse to the target position. 

 Call view pan function: 
a. Select from the following methods to call the view pan tool: 

 In the drawing toolbar, click  Pan. 
 In the menu bar, click View → Pan. 

b. Select a datum point, press the left mouse button, drag to the target position 
and release the mouse. 

c. Right click or press Esc to exit view pan. 

5.2.4 Zoom 
Zoom in and out of view in real time. Through changing the size of the shown area and 
objects, you can draw objects more precisely. 

Operation Steps: 

1. In the menu bar, click View → Zoom to call real time zoom. 

2. Select from the following methods to perform real time zoom: 
o Scroll up the mouse wheel to zoom in the view and scroll down the mouse 

wheel to zoom out the view. 
o Press and drag up the left mouse button to zoom in the view, and press and 

drag down the left mouse button to zoom out the view. 
o In the numeric keypad, press + to zoom in the view, and press - to zoom out 

the view. 
3. Right click or press Esc to stop. 

5.2.5 Zoom by Rect 
Zoom in the part of the graphic to the view window size. 

Operation Steps: 

1. Select the following methods to call zoom by rect function: 

o In the drawing toolbar, click  Zoom by Rect. 
o In the menu bar, click View → Zoom by Rect. 

2. Left click on the drawing window, drag the mouse to form a rectangle and left click 
again. The area formed by the rectangle zoom in. 
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5.2.6 Best View 
Display all graphics in the window with adaptive size. 

Operation Steps: 

 In the drawing toolbar, click  Best View. 

 In the menu bar, click View → Best View. 

 In the numeric keypad, press *. 

5.2.7 Show/Center Current Point 
In the menu bar, under the drop-down key of View, the view setting of the current point: 

 Show current point: The current point refer to the current position of the cutting 
head, the icon is as follows: 

 
 Center current point: Show the layout of the current drawing area with the current 

point as the center. 

5.2.8 Show Setting 
In the menu bar, under the drop-down key of View, buttons are provided to control the 
display effect. 

 
Check the button in the red box, the show effect will take effect immediately, and you can 
see the change of the show effect in the drawing area. If the button is checked, it means 
that the corresponding effect is turned on, otherwise, it means that the effect is not turned 
on. 

5.2.9 Show Track 
Show the machining track with a red line. During simulation, the simulated machining track 
is displayed in real time. 

In the menu bar, select from the drop-down key of View → Show Track: 

 Hide track 

 Show machining track 

 Show feedback track 
Note: Three options, only one can be chosen. 
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If you want to clear the machining track, select any of the following methods: 

 In the menu bar, click View → Clear Track. 

 In the common toolbar, click Clear → Trajectory. 

5.2.10 Fill Mode 
View the closed graphics set to Fill. In this mode, the closed graphics of Fill are filled and 
displayed, and the other graphics are displayed in wireframe. 

In the menu bar, click View → Fill Mode to switch to fill mode: 

 
To switch back to the system default wireframe mode, in the menu bar, click View → 
Wireframe Mode, all graphics will be displayed in wireframe mode. 

5.3 Edit Graphic 

5.3.1 Transform Graphic 

In the common toolbar,  drop-down key provides many geometric 
transformation functions. Most of the commonly used geometric transformations only need 

to click  drop-down key. Select the target and it can be completed. 

 
5.3.1.1 Translate 
Move the graphic in a certain line direction and change the coordinate position of the 
graphic without changing the size of the graphic. 

Operation Steps: 

1. Select the object. 
2. Select any of the following methods to perform translate: 

 Press the left mouse button and drag the graphic. 

 In the keyboard, press ↑, ↓, ←, →. 

 Call translate function: 
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a. In the common toolbar click → Pan or in the menu bar, click Edit 

→ Pan. 

b. Left click to select the reference point position. 
c. Left click to select the target position. 

5.3.1.2 Rotate 
Rotate the graphic at a certain angle around a point in a certain direction. 

Operation Steps: 

1. Select the object. 
2. Select any of the following methods to perform rotate: 

 After entering the rotation angle in the Rotation input box in the common toolbar, 
press Enter to confirm. 

o When the object is a rectangle or text, the lower left point of the object is the 
rotation center: 

 
o When the object is star, polygon or ellipse, the center point of the object is 

the rotation center: 

 
 Rotate any angle: 

a. In the common toolbar click  Transf→ Rotate any Angle or click 
Edit → Rotate any Angle in the menu bar. 

b. Left click to select the rotation center. 
c. Move the cursor to adjust the rotation angle, left click to confirm. Or enter the 

angle in the input box of the rotation center and press Enter to confirm. 

 90° or 180° rotation: 

a. In the common toolbar click  Transf→ Clockwise Rotate 90 / 
Anticlockwise Rotate 90 / Rotate 180 or click Edit → Clockwise Rotate 90 
/ Anticlockwise Rotate 90 / Rotate 180 in the menu bar. 

5.3.1.3 Mirror 
Including vertical and horizontal mirror: 

 Vertical Mirror: Flip up and down with the graphic center point as the rotation 
center. 
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 Horizontal Mirror: Flip left and right with the graphic center point as the rotation 
center. 

After selecting the target object, select the following methods to perform mirror: 

 In the common toolbar, click → Horizontal Mirror / Vertical Mirror. 

 In the menu bar, click Edit → Mirror → Horizontal Mirror / Vertical Mirror. 

5.3.1.4 Align 
Change the relative position between graphics to align them. 

Operation Steps: 

1. Select multiple objects. 
2. Select any of the following methods to perform align: 

o In the drawing toolbar, click  Center Point Alignment. 
o In the menu bar, click Edit → Align, select the alignment method in the 

submenu. 

o In the common toolbar, click → Align, select the alignment 
method in the submenu: 

 Align Left 
 Align Right 
 Align Top 
 Align Bottom 
 Align Center Point 
 Align Horizontally 
 Align Vertically 
 Distribute Horizontally 
 Distribute Vertically 

System auto perform alignment. 

5.3.2 Size Scale 
Scale the graphic proportionally and change the size of the graphic. The software provides 
7 rapid size scale. 

 
 

Note: After modifying the size, the lead out line and kerf compensation will not be 
transformed at the same time, that is, the value remain unchanged. 

5.3.2.1 Multiple Quick Scale 
Operation Steps: 

Select the object. In the common toolbar, click  → select the scale method from 
the drop-down menu. 
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5.3.2.2 Accurate Size Scale 
Operation Steps: 

1. Select the object. 

2. In the common toolbar, click  → Fixed Scaling, or in the menu bar, click 
Edit → Scale → Fixed Scaling. 

 
3. Input size. 

o When the lock state in the dialog box is , you can select the Command 
Used Size, and when entering a new size, the length and width will be 
modified according to the size ratio of the original image. 

o When the lock state in the dialog box is , the Command Used Size cannot 
be selected. When entering a new size, the length and width can be entered 
separately. 

4. Select scale center. 
The scale center can specify the positional relationship between the new graphics 
and the original graphics after scaling. For example, if you select "top left", it means 
that after scaling, the new graphics and the original graphics are aligned according 
to the top left corner, and other parts are scaled based on the top left corner. 

5.3.2.3 Interactive Scaling 
Operation Steps: 

1. Select the object. 

2. In the common toolbar, click  → Interactive Scaling, or click Edit → 
Scale → Interactive Scaling in the menu bar. 

3. Left click to select the scale center point. 
4. After left click, move the cursor to adjust the scale ratio. 
5. Left click to confirm. 

5.3.3 Group 
Used to form multiple selected objects into a group. 

Operation Steps: 

1. Select multiple objects. 
2. Select any of the following methods to perform group: 
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 In the common toolbar, click . 

 Right click to call the shortcut menu, click Group. 

 In the menu bar, click Edit → Group/Disband → Group. 
The group effect diagram is as follows: 

 
5.3.4 Ungroup 
It is used to disband the combined group into multiple graphics. 

Operation Steps: 

1. Select the target group. 
2. Select any of the following methods to perform ungroup: 

 In the common toolbar, click . 

 Right click to call the shortcut menu, click Break Group. 

 In the menu bar, click Edit → Group/Disband → Ungroup. 

5.3.5 Merge 
Merge multiple path objects into a single path object to connect disconnected graphics. 

Merged objects must meet the following conditions: 

 Non-closed object 

 Non-dot 

 Non-text 

 Non-group 
Before merging objects, it is suggested to enable catch. 

Operation Steps: 

1. Select multiple objects. 
2. Select any of the following methods to open the Join dialog: 

o In the common toolbar, click  → Merge. 
o Right click to call the shortcut menu, click Join. 
o In the menu bar, click Edit → Merge. 

 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 57 / 161 

3. Set the parameters Tolerance and Priority. 
o Tolerance: The maximum distance between objects that needs to be 

merged. 
o Priority: When there are more than three end points satisfying the merge 

tolerance at the same merge position, the objects with the closest distance, 
the longest length, and the same direction are preferentially merged. 

4. Optional: Check Join among Different Layers. The system merges objects of 
different layers into the layer with a higher layer order. 

The merge effect diagram of different priority is as follows: 

 
5.3.6 Explode 
Delete extra lines to trim the toolpath. It usually applies to polylines. 

Use it together with Merge function, to correct mistakes by drawing and make sure 
machining quality. 

According to different machining objects, it can be divided into: 

 If the object is a group: Explode objects is equal to Ungroup. 

 If the object is text: Explode objects is equal to Convert Text to Graphic. 
Operation Steps: 

1. Select the object. 
2. Select any of the following methods to perform explode: 

 In the common toolbar, click  → Explode. 

 In the menu bar, click Edit → Explode. 
The explode effect diagram is as follows: 

 
5.3.7 Break 
Used to cut-off graphics into multiple polylines. 

It is usually used in the following situations: 
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 Through brake processing, connect the cutting part to its surrounding material. It 
equal to micro joint. 

 Cut extra objects during drawing objects. Easily cut out ideal shapes. 
Select any of the following methods to perform break: 

 Automatically: Auto execute break on all selected objects according to the set value. 

 Manually: Select break position by yourself, only perform break on one object at a 
time. 

5.3.7.1 Automatically 
Operation Steps: 

1. Select the object. 
2. In the menu bar, click Edit → Break to open the Break dialog box: 

 
3. After selecting Automatically, enter the Counts and Length of the break line. 

The automatic break effect diagram is as follows: 

 
5.3.7.2 Manually 
Operation Steps: 

1. In the menu bar, click Edit → Break to open the Break dialog box: 

 
2. After selecting Manually, enter the Length of the break line. 

3. Click OK, the cursor change to . 
4. Left click to select the position for breaking. 
5. Right click to finish breaking. 

The mnually break effect diagram is as follows: 
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5.3.8 Trim 
The trim function use the intersection point as the trim point to delete the selected part. 

Operation Steps: 

1. In the menu bar, click Edit → Trim , the cursor change to . 
2. After selecting the target to be trimmed, left click, the graphic will use the 

intersection point as the trim point, and the selected target will be deleted. 
The trim effect diagram is as follows: 

 
5.3.9 Extend 
The extend function is to extend a line to another line to form an intersection, making the 
line closed. Extend is often applied to unclosed graphics, and does not support line 
segments without intersection after extend. 

Operation Steps: 

1. In the menu bar, click Edit → Extend, . 
2. Move the cursor to the line segment that needs to be extended, and the graphic will 

display the effect of extend. 
3. Left click to confirm extend. 

 
5.3.10 Common Edge 
Common edge is used for overlap edges between graphics, so that they share a boundary, 
which avoid repeated cutting of the same boundary during machining. 

The following conditions must be met before common edge: 

 Closed graphics 

 Common boundaries are lines or arcs 
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 Graphics with common points 

 
Operation Steps: 

1. Select multiple objects. 
2. Follow any of the following steps to perform common edge: 
3. Select any of the following methods to open the CoEdge dialog box: 

o Right click to call the shortcut menu, click CoEdge. 
o In the menu bar, click Tool Path → Common Edge. 

o In the common toolbar, click  drop-down key → Advanced 
Settings. 

 
4. Select CoEdge strategy: 

o Grid: Cut internal graphics first. 
o Type C: The tool path is type C cutting graphics. 

5. Optional: If the co-edge strategy is selected as C Type, set the machining order: 
o From Buttom to Top: According to the order of the center point of each area 

from bottom to top. 
o From Left to Right: According to the order of the center point of each area 

from left to right. 
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o Diagonal Extend: Select the closed area in the lower left corner to start 
processing. The extend direction is from the lower left corner to the upper 
right corner. 

o Stair-Step Extend: Suitable for regular matrix graphics. The machining tool 
path is stepped, and the extend direction is from the lower left corner to the 
upper right corner. 

6. Optional: If the CoEdge strategy is selected as C Type, single part has inner hole 
can specify the sorting strategy of the inner hole graphics, that is, set the inner hole 
sorting: 

o From Bottom to Top: Machining in the order of the center points of each 
area from bottom to top. 

o From Left to Right: Machining in the order of the center points of each area 
from left to right. 

o From Top to Bottom: Machining in the order of the center points of each 
area from top to bottom. 

o From Right to Left: Machining in the order of the center points of each area 
from right to left. 

o Local Shortest Path: The shortest empty path between the cutting of one 
graphic and the start of cutting of another graphic is the "local shortest path". 

7. Optional: If you need to perform other operations, in the Other area, check the 
following options: 

o CoEdge among Layers: Graphics CoEdge between different layers. 
o Point CoEdge: The graphics contain common points are converted into 

groups. 
o Extend Starting Point: to extend the tool path in the opposite machining 

direction through the start point and turn on the laser in advance, helping 
completely cut the start point and avoid over-burning. It is applicable to 
rectangular objects. 

o Prevent Collision: to avoid colliding with the cutting head after cutting parts 
in the first region of shared objects. the CoEdge will be cut in the second 
region. 

Note: Only valid for C type CoEdge. Otherwise, maintain the original 
common edge path, and cut the common edge part when machining the first 
area. 

o Over Cut: Over cut strategy. 
o Border First: The outer frame of the part is preferentially CoEdge. 

8. After the setting is complete, click OK, and the graphics will become a group after 
CoEdge. 

5.3.11 Array 
It is used to copy the machining objects and arrange them in order, so as to improve 
machining efficiency. 

Array include the following: 

 Rectangular Array 

 Circular Array 

 Manual Array 

5.3.11.1 Rectangular Array 
Copy the graphic along the rectangular array. 

Operation Steps: 
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1. Select the object. 
2. Select one of the following to open the Rectangular Array dialog box: 

o In the common toolbar, click . 

o In the common toolbar, click  drop-down key → Rectangular 
Array. 

o In the common toolbar, click Drawing → Array → Rect Array. 

 
3. Set the rows and columns for rectangular array. 
4. In the Offset area, set the offset method: 

o Offset: Translate based on the center of the graphic. 
o Distance: Translate based on the graphic frame. 

5. Select the row and column directions for rectangular arrays. 
The result is as follows: 

 
5.3.11.2 Circular Array 
There are two modes for circular array: 

 Array by center: Make an array based on the specified circle center coordinates. 
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 Array by radius: Make a circle array around the currently selected graphic as the 
datum (circle center). 

Operation Steps: 

1. Select the object. 
2. Select one of the following to open the Circular Array dialog box: 

o In the common toolbar, click  drop-down key → Circular Array. 
o In the common toolbar, click Drawing → Array → Circle Array. 

 
3. Set the array method. 

o Array by center: Check Array by Center to set the coordinates of the 
rotation center point of the circular array. 

o Array by radius: Check Array by Radius, set Radius and Starting Angle(A) 
parameters. 

4. Sets the parameters for the Array Param area. 
o Array Counts: Total number of circles to copy. 
o Array Angle: Total column offset angle. 

5. Check or uncheck Rotated when Arrayed as required. 
The result is as follows: 
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5.3.11.3 Manual Array 
Set the row distance and column distance, delineate the planning area by dragging the 
mouse, and quickly copy the selected graphics in an array. 

Operation Steps: 

1. Select the object. 
2. Select one of the following to open the Manual Array dialog box: 

o In the common toolbar, click  drop-down key → Manual Array. 
o In the common toolbar, click Drawing → Array → Manual Array. 

 
3. Set Row Dist and Col Dist for manual array. 

o Row Dist: Translate left and right based on the graphic frame. 
o Col Dist: Translate up and down based on the graphic frame. 

4. Select the start point for the array. 
o Take the selected object as the start point: 

i. Click OK. The cursor turns into . 
ii. Drag the mouse to delineate the planning area, select the end point, 

and left click. 
o Manual select the start point: 

i. Check Start with Selected Graph. 
ii. If you need to delete the original graph, check Delete the Original 

Graph. 
iii. Click OK, left click to select the start position. If need to re-select the 

start position, right click. 
iv. Drag the mouse to delineate the planning area and the cursor turn into 

. Select the end point, left click. 
The result is as follows: 
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5.4 Graphic Preprocessing 
When importing external graphics, the software can be set to automatically optimize the 
graphics to achieve better machining results. For details, please see Preprocess. 

If you need to manually optimize the graphics, you can use  button function in 
the common toolbar. Select the graphics to be processed, click the corresponding button, 
and operate according to the prompts. 

 
5.4.1 Preprocess 
Automatically process of graphics at once. 

Operation Steps: 

1. Select the object. 
2. Select any of the following methods to open the Preprocessing dialog box: 

o In the common toolbar, click . 
o Right click to call the shortcut menu, click Preprocessing. 
o In the menu bar, click Edit → Instant Pre-process. 

 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 66 / 161 

3. Check the preprocessing item and set the parameter range. 
o Simplify Curves 
o Delete Overlap Line 
o Join 
o If you need to delete dots, check Delete Dots, and the system will 

automatically delete dots. 
o If you need to delete small circles within the diameter range, check Delete 

Mini-circles, and set Max Dia., the system will automatically delete small 
circles within the diameter range. 

o If you need to delete small curves within the size range, check Delete Mini-
curves, and set Max Scale, the system will automatically delete small 
curves within the size range. 

o Intersection Trim 
o Polyline to Circle 
o Auto set fill/unfill 
o Highlight unclosed 
o Auto sorting 
o Part information: After checking, set the identifier and quantity of the part 

name. When drawing CAD drawings, you can use the set identifier to set the 
part information. After importing to the system software, you can quickly 
obtain the part name and number. 

o DXF layer/Color map: Set the corresponding relationship between the layer 
color of the system software and the CAD drawing. 

4. Optional: Check Merge Similarity Geometry, in the menu of imported parts, the 
same parts will only be displayed once in the parts list, and the number will be 
superimposed, and not all will be expanded. 

5. Optional: Check Apply when Importing. The system processes the objects 
automatically according to the selections above after importing a toolpath file. 

5.4.2 Smooth 
Smooth processing is performed on multi-segment polyline graphics, and the processed 
graphics are smoother to ensure smooth machining. 

Operation Steps: 

1. Select the object. 
2. Select any of the following methods to perform smooth curves: 

o In the common toolbar, click  → Smooth. 
o Right click to call shortcut menu, click Smooth. 
o In the menu bar, click Edit → Smooth. 

After smoothing curves, the prompt Curve Smoothing Successful shows. 

5.4.3 Curve Segmentation 
It is used to cut-off the graphics and break the lines of the graphics. 

Common usage scenarios are as follows: 

 Through break processing, the cut parts are connected with the surrounding 
materials, which is the same as micro joint. 

 Cut redundant graphics in the graphics drawing stage, which is convenient for 
cutting out ideal shapes. 

The difference between curve split and Break: 
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 The difference in the method: Split can only select the break point manually, and 
the break support automatic and manual selection of the break point. 

 The length of the break point: Split cannot be set, and the break support setting the 
length of the break point. 

Operation Steps: 

1. Select any of the following methods to enable curve segmentation: 

o In the common toolbar, click  → Curve Segmentation. 
o Right click to call shortcut menu, click Curve Segmentation. 
o In the menu bar, click Edit → Curve Segmentation. 

2. At this point the cursor change to . At the position of the break point, left click. 
The segmentation effect diagram is as follows: 

 
5.4.4 Delete Overlap Line 
To delete overlap lines need to meet the following conditions: 

 Two graphics that coincide exactly: 

 
 Lines that overlap between lines and graphics: 

 
 Lines where the graphic overlaps itself: 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 68 / 161 

 
Operation Steps: 

1. Select multiple objects. 
2. Select any of the following methods to open the Delete Overlap Lines dialog box: 

o In the common toolbar, click  → Delete Overlap Lines. 
o Right click to call shortcut menu, click Delete Overlap Lines. 
o In the menu bar, click Edit → Delete Overlap Lines. 

 
3. Set the following parameters: 

o Tolerance: To delete overlap lines, the distance between two lines must be 
within the maximum tolerance range. 

o Min Length: To delete overlap lines, the overlap length of the two lines must 
be greater than the minimum length. 

The effect of delete overlap lines is as follows: 

 
5.4.5 Delete Tiny 
It can automatically delete dots, tiny circles and tiny curves according to the set conditions. 
The size of the tiny circles and tiny curves to be deleted can be set. 

Operation Steps: 

1. Select the object. 
2. Select any of the following methods to open the Delete Tiny Objects dialog box: 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 69 / 161 

o In the common toolbar, click  → Delete Tiny. 
o In the menu bar, click Edit → Delete Tiny. 

 
3. Select the item to be deleted and set the size. 
4. Click OK, and a prompt box will pop up indicating the number of tiny graphics to be 

deleted. 
The effect diagram of deleting tiny graphics is as follows: 

 
5.4.6 Simplify Curve 
It is used to reduce the number of control points for polylines, so as to speed up the 
response time to object operations. 

Control points are special points that control and adjust the shape of a curve. 

Operation Steps: 

1. Select the object. 
2. Select any of the following methods to open the Simplify Curve dialog box: 

o In the common toolbar, click  → Simplify Curve. 
o In the menu bar, click Edit → Simplify Curve. 

 
3. Set the tolerance and click OK. 

The system automatically reduces the number of control points for polylines within the set 
tolerance. 

5.4.7 Convert Polyline to Circle 
It is used to turn closed polylines shaped like circles into circles. 

Operation Steps: 

1. Select the object. 
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2. Select any of the following methods to open the Convert Polyline to Circle dialog 
box: 

o In the common toolbar, click  → Convert Polyline to Circle. 
o Right click to call shortcut menu, click Convert Polyline to Circle. 
o In the menu bar, click Edit → Polyline to Circle. 

 
3. According to the schematic diagram, set parameters max tolerance and max 

relative error. 
After successfully turning polylines into circles, the following dialog box pop-up. The result 
is as follows: 

 
5.4.8 Trim Self-intersection 
Separate the self-intersecting polyline graphics and cut-off redundant lines. 

Operation Steps: 

1. Select the object. 
2. Select any of the following methods to open the Intersection Trim dialog box: 

o In the common toolbar, click  → Trim Self-intersection. 
o In the menu bar, click Edit → Trim Self-intersection. 

 
3. Set the length, click OK, the software will automatically cut-off the lines within the 

length range. 
The self-intersecting trim effect diagram is as follows: 
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5.4.9 Convert Text to Graphic 
Convert text to polylines to ensure that technic can be added later. 

Operation Steps: 

1. Select the object. 
2. Select any of the following methods to perform convert text to graphic: 

o In the common toolbar, click  → Convert Text to Graphic. 
o Right click to call shortcut menu, click Text to Polylines. 
o In the menu bar, click Edit → Convert Text to Graphic. 

5.5 Auxiliary Tool 

5.5.1 Catch 
More precise positioning of feature points for some graphics when drawing objects. 

When the mouse is close to a feature point, the system can easily catch it, facilitating 
accurate connection between graphics. 

5.5.1.1 Turn On/Off the Catch Function 
In the menu bar, click Drawing → Catch. If the Catch option is checked, it is turned on, 
and if it is not checked, it is turned off. In the corresponding common toolbar, the Catch 

Options button will change,  indicating that the catch function is off,  and that 
indicators catch function is turned on. 

5.5.1.2 Set Catch Options 
Operation Steps: 

1. Select the following method to open the Catch Options dialog box: 

o In the common toolbar, click  Catch Options. 
o In the menu bar, click Drawing → Catch Options. 
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2. Check the feature items that you need to catch, and adjust Catch Sensitivity. 

It is easier to get the feature points with higher catch sensitivity. 
3. If Custom is checked in Polar Axis area, to set the incremental angle. For details, 

please see Polar Axis Inc. Angle. 

5.5.1.3 Polar Axis Incremental Angle 
Set the incremental angle, catch at the set Incremental Angle, every time Incremental 
Angle is rotated, the system will give blue polar axis prompts in the horizontal and vertical 
directions. 

Operation Steps: 

1. In the menu bar, click Drawing → Polar IncAngle. Polar Axis Inc. Angle dialog 
box pop-up. 

 
2. Set incremental angle and check Enable. 

5.5.2 Measure Distance 
It is used to measure distance, X-axis / Y-axis offset and the vector angle between two 
points and the angle with the positive X-axis. 

Operation Steps: 

1. Select any of the following methods to call the function of measure distance: 

o In the drawing toolbar, click  Measure. 
o In the menu bar, click View → Measure. 

2. Left click to select the start point for measuring. 
3. Move the cursor to select the end point. The measurement result shows near the 

end point. 
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5.5.3 Graphic Detection 
After importing or drawing graphic, check whether the current graphic has unclosed, self-
cross, intersection and overlap, quickly lock the graphic. 

Operation Steps: 

1. Select the object. 
2. In the menu bar, click View → Graphic Detection, and the Shape Check dialog 

box will pop-up: 

 
3. Check the items that need to be detected, click OK, after the detection is completed, 

the dialog box of Check Information will pop-up: 

 
4. Check whether to select unclosed objects according to the needs. 
5. Click OK, in the Drawing Area the graphs that meet the conditions will be displayed 

with dotted lines and selected by red boxes: 

 
5.5.4 Quantity Modify 
Batch process the selected graphics and the graphics that are exactly the same as them. 

Operation Steps: 
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1. Select a single object. 
2. Select any of the following methods to enable quantity modify: 

o In the menu bar, click Edit → Quantity Modify. 
o Right click in the drawing area and select Quantity Modify. 

After the quantity modify function is enabled, the drawing interface only display the 
selected objects. 

3. Optional: Check any of the following options: 

 
o To modify only the selected graphics, check Modify Itself. 

Otherwise, quantity modify the selected graphic and its identical graphic. 
o If not modify graphics with similar rotation angles to the selected graphics, 

check Distinguish Angle. 
4. Modify according to actual needs, the gray button means that it cannot be operated. 
5. After modification, click OK. The effect diagram of quantity adding lead line: 

 
5.5.5 Group Editing 
A group is to combine multiple graphics, or even multiple Group together to form a group, 
and the whole group will be treated as a whole. 

Quantity modify is to modify the graphics in the group in quantity, and at the same time, 
you can choose whether to modify the same group in quantity. 

Operation Steps: 

1. Select a single group. 
2. Select any of the following methods to enable group editing: 

o In the menu bar, click Edit → Group Editing. 
o Right click in the drawing area, select Group Editing. 

After the group editing function is enabled, only the selected group will be displayed 
on the drawing interface. 

3. Optional: Check any of the following options: 

 
o If only modify the selected group, check Modify Itself. 

Otherwise, quantity modify the selected group and its identical group. 
o If not modify graphics with similar rotation angles to the selected graphics, 

check Distinguish Angle. 
4. Modify according to actual needs, the gray button means that it cannot be operated. 
5. After modification, click OK. The effect diagram of group adding lead line: 
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6 Machining Technic 
6.1 Overview 
This chapter introduce the setting of technic related functions. Since most of the technic 
parameters are directly related to the material being cut, the laser and the gas pressure 
used, they need to be set according to the actual technic requirements. The parameters in 
this chapter, including those in the picture, are only example and cannot be considered as 
guidance parameters. 

Warning: Please set parameters carefully. Inappropriate or wrong parameters may cause 
poor cutting results or even damage the machine tool. 

6.2 Machining Direction 
Display and change the machining track direction in the tool path. Before changing the 
machining direction, to show the machining direction. 

Select any of the following methods to display the machining direction: 

 In the common toolbar, click  Show Direction. 

 In the menu bar, click View → Show Direction. 

6.2.1 Auto Set Machining Direction 
Auto set the machining direction for the selected and satisfied objects according to the set 
value. 

Operation Steps: 

1. Select one or more graphics. 
2. Select any of the following methods to open the Direction dialog box: 

o In the common toolbar, click  drop-down key → Advanced 
Settings. 

o In the menu bar, click Technics → Mach DIR → Set. 

 
3. Select the machining direction. 

Note: If the selected object is an unlocked graphic, it cannot be selected: 

o CCW for fill while CW for unfill 
o CW for fill while CCW for unfill 

4. (Optional:) If need to set the machining direction, the machining direction of the 
primitives in the group will not change, check Skip Groups. 

5. Click OK to automatically generate the machining direction. 

6.2.2 Manual Set the Machining Direction 
Auto select the machining direction. 
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Operation Steps: 

1. Select one or more graphics. 
2. According to different needs, select to perform the following operations: 

If… So… 

Reverse the machining direction of the 
selected graphics 

Select any of the following methods to perform the 
reverse:  

▪ In the menu bar, click Technics → Mach DIR → 
Reverse.   

▪ In the common toolbar, click  drop-
down key → Reverse. 

▪ Right click to call the shortcut menu, click Reverse. 

Unify the machining direction of the selected 
graphics into CW 

In the common toolbar, click  drop-
down key→ CW. 

Unify the machining direction of the selected 
graphics into CCW 

In the common toolbar, click  drop-
down key→ CCW. 

6.3 Micro Joint 
During laser cutting, the cut parts cannot fall from the gap in the support bars or be lifted 
up when held by the support bars, and the high-speed moving cutting head may collide 
with them. Use Micro Joint to connect parts with surrounding materials so that the 
materials do not fall and the work of sorting is eliminated. 

6.3.1 Automatic Micro Joint 
Automatically add micro joint to the selected objects according to the set value. 

Operation Steps: 

1. Select the object. 
2. Select any of the following methods to open the Micro Joint dialog box: 

o In the common toolbar, click  drop-down key → Automatic 
Micro Joint. 

o In the menu bar, click Technics → Micro Joint → Micro Joint. 
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3. Select by counts or by space micro joint. The system automatically performs micro 
joint on the selected objects according to the set value. 

4. In the Applied Range area, set the size of the large and small graphics. Check the 
graphic range of the micro joint. 

5. In the Advanced Options area, check the options as required: 
o Micro joint add lead line, set the lead line parameters after checking 
o Automatically modify the start point to micro joint 
o Unclose start point add micro joint 
o Corner evading, set the following parameters after checking, otherwise all 

points support micro joint. 
 Evading Length: Range: 0.001mm~10mm 
 Corner Angle: Range: 90°~180° 

6. After setting, click OK, the system will automatically add micro joint according to the 
set value. 

When By Counts is selected and the number is set to 2. The before and after effect of 
automatic micro joint are as follows: 

 
If need to view the position of the added micro joint more clearly, in the menu bar, click 
View → Show Micro Joint, the effect picture is as follows: 

 
6.3.2 Manual Micro Joint 
Select the micro joint position. When setting manually, it is recommended to enable the 
catch function. 

Operation Steps: 

1. Do not need to select the object, select any of the following methods to open the 
Manual Micro Joint dialog box: 

o In the common toolbar, click  Micro Joint. 
o In the menu bar, click Technics → Micro Joint → Manual Joint. 
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2. Set the line length. 
3. Check Corner Evading, and set the following parameters, otherwise all points 

support micro joint. 
o Evading Length: Range: 0.001mm~10mm 
o Corner Angle: Range:90°~180° 

4. Check options as needed: 
o Auto modify the start point to micro joint 
o Micro joint add lead line, and set the lead line parameters after checking it 

5. Click OK. The cursor turn to . 
6. Left click to select the micro joint position. 
7. Right click to exit the manual micro joint function. 

The effect diagram of manual micro joint is as follows: 

 
If need to view the position of the added micro joint more clearly, in the menu bar, click 
View → Show Micro Joint, the effect picture is as follows: 
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6.3.3 Explode Micro Joint 
If you want to separately modify the part after the micro joint is separated, you can use the 
Explode Micro Joint function. Through Explode Micro Joint the unclosed graphics after 
the separation will be regarded as a separate individual to modify. 

For example, if you want to add leads to the micro-connection part, you need to Explode 
Micro Joint first, and then add the leads. 

Operation Steps: 

1. Select the object. 
2. Select any of the following methods to perform the explode micro joint operation: 

o In the common toolbar, click  drop-down key → Explode Micro 
Joint. 

o In the menu bar, click Technics → Micro Joint → Explode Micro Joint. 

6.4 Lead Line 
Set the lead line in the waste area to avoid machining error or workpiece damage caused 
by the laser stay at the start point for a long time at the beginning of machining. Make 
machining more precise. 

The types of lead line: 

 Lead-in: Including line, arc and hook type, the hook type is formed by connecting 
arc and line. 

 Lead-out: Including line and arc type. 
The selection of the lead line type is determined by the cutting technic. According to the 
actual situation, set relevant parameters such as Speed, Lead Line Height on the Lead 
Line Technics page of Layer. 

6.4.1 Automatically Set Lead Line 
Automatically add lead line to the selected object according to the set value. 

Operation Steps: 

1. Select one or more objects. 
2. Select any of the following methods to open the Lead Line dialog box: 

o In the common toolbar, click  Lead. 
o Right click to call the shortcut menu, click Lead Line → Set. 
o In the menu bar, click Technics → Lead Line → Set. 
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3. In the Lead-in and Lead-out areas, set relevant parameters. The parameter 

descriptions are as follows: 
Parameter Description 

Type Including line, arc and hook type, where the hook type is composed of arc and line. 

Angle ▪ The angle of line type lead line refers to the angle between the lead line and the 
tangent line at the intersection point of the primitive. 

▪ The angle of the arc type lead line refers to the central angle. 

Length ▪ The length of line and arc type lead line refers to the length of line and arc. 

▪ The length of the hook type lead line refers to the sum of the radius of the arc part 
and the length of the line part. 

Radius The radius of the hook type lead line is the radius of the arc part of the lead line. 

Add tiny circle 
in start point 

In order to solve the problem that the accumulation of slag affect the cutting effect 
when piercing thick plates. Adding a suitable small round hole at the start point of the 
lead line can cut off the slag at the same time, so as to ensure the cutting quality. 

Circle radius The radius of the tiny circle at the start point of the lead line. 

4. Optional: If it is a closed graphic, set the following parameters in the Seal area: 
o Gap: Unclosed lead line means not cutting. 
o Over: Seal lead line. 

In the menu bar, click Technics → Lead Line → Seal → Gap/Over to edit or 
delete the gap and overcut separately. 

5. Select any of the following methods to set the lead line position: 
o If select Automatic Lead Position, select as needed: 

 Corner First: Prioritize adding lead lines at corners. 
 Edge First: Add lead lines on the longest edge first. 
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o If select Set by Total Length (0~100), set the percentage of the total side 
length of the graphic from the start point of machining to the position of the 
lead line. 
Only applie to closed graphics. 

6. In the Advanced Options area, select as desired: 
o Retain Position, Change Leads Type 
o Retain Leads Type, Change Position 
o Close only 
o Auto Set Fill/Unfill 
o Fill only 
o Unfill only 
o Check Lead-in/out Line: If Check Lead-in/out Line is checked, the 

software will automatically check whether the lead line is reasonable, and if it 
is reasonable, a dialog box will pop-up and display "check lead line passed". 

7. Click OK. 
The effect diagram of the lead line is as follows: 

 
6.4.2 Manually Set Lead Line 
Use the mouse to specify the position of the lead line, and add the lead line according to 
the set value. 

Operation Steps: 

1. Select one or more objects. 
2. Select any of the following methods to open the Leader Line dialog box: 

o In the common toolbar, click  Lead. 
o Right click to call the shortcut menu, click Lead Line → Set. 
o In the menu bar, click Technics → Lead Line → Set. 

3. In Lead-in, Lead-out and Seal areas, set relevant parameters. For details, please 
see Automatically Set Lead Line. 

4. In the Position area, click Set by Mouse to return to the drawing area, and the 

cursor changes to . 
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5. Click the graphic boundary to manually specify the position of the lead line. 
6. After setting, right click or press Esc key to exit the tool. 

6.4.3 Modify Lead Line 
Manually modify the position of the lead line. 

Operation Steps: 

1. Select any of the following methods to call the function of manually set the start 
point: 

o In the common toolbar, click . 
o Select any object, right click to call the shortcut menu, click Lead Line → 

Start Point. 
o In the menu bar, click Technics → Lead Line → Set Start Point. 

2. As needed, do the following: 
o Left click on the graphic boundary. 

Only modify the position of the lead line, not modify the angle and length. 
o After left clicking outside the graphic, left click on the graphic boundary. 

Draw a line type lead line from outside the graphic to the graphic. 
3. Right click or press the ESC key to exit the start point function. 

6.4.4 Check Lead Line 
Check whether the lead line is reasonable, if not, give a modification suggestion and 
modify it automatically. 

Operation Steps: 

1. Select one or more graphics. 

2. In the common toolbar, click  drop-down key → Check the Lead Line. 
Result: 

 If there is an unreasonable lead line, it will be modified automatically. 

 If the system cannot automatically modify the unreasonable lead line, a prompt box 
will pop-up. 

6.5 Start Point 
The start point is the start point of cutting each part. Each independent graphics has one 
and only one start point. The setting of the start point can facilitate the planning of the path, 
or set the start position of the tool according to the actual situation on site. 

If there is a lead line, set the start/end point of the lead line; if there is no lead line, set the 
start point of machining, and start machining the graphic from the selected current point. 

Operation Steps: 

1. Select any of the following methods to call the function of manually set the start 
point: 

o In the common toolbar, click . 
o Select any object, right click to call the shortcut menu, click Lead Line → 

Start Point. 
o In the menu bar, click Technics → Lead Line → Set Start Point. 

2. Move the mouse, left click to select the start point of the start line. 
3. In the graphics, select the end point of the start line with the left click to form the 

start line. 
4. Optional: Modify start point: 
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o Whole moving start line: Move the mouse along the graphic, and the start 
line will also move along with it. Left click the graphic to select another place 
as the start point. 

o Reset the start line: Repeat steps 2~3. 
5. Right click or press ESC key to exit the start point function. 

6.6 Seal 
A seal is formed between the cutting start point and the end point of the part, and the seal 
method is divided into gap and overcut. 

 Gap: It means to keep a certain distance between the start point and the end point, 
which is used for the adhesion of parts and plates, and can prevent parts from 
warping after cutting. 

 Overcut: It means that the end point continues to cut forward for a certain distance 
after passing the start point, the purpose is to remove the possible start point slag. 

6.6.1 Set Gap 
Operation Steps: 

1. Select one or more graphics. 

2. In the common toolbar, click  drop-down key → Gap to open the Gap 
dialog box: 

 
3. Set the length of gap. 
4. Click OK. 

Add gap effect diagram: 

 
6.6.2 Set Overcut 
Operation Steps: 

1. Select one or more graphics. 

2. In the common toolbar, click  drop-down key → Overcut to open the 
Over dialog box: 
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3. Set the length of the overcut. 
4. Click OK. 

Add overcut effect diagram: 

 

6.7 Unfill / Fill 
Unfill is used to preserve the outer of the closed graphics during machining. Fill is used to 
preserve the inner of closed graphics during machining. 

Operation Steps: 

1. Select closed graphics. 
2. Select any of the following methods to select the Unfill/Fill command: 

o In the common toolbar, click . 
o Right click to call the shortcut menu, click Unfill/Fill. 
o In the menu bar, click Technics → Unfill/Fill. 

3. Select the setting method in the submenu: 
o Select Unfill/Fill, and manually set the selected graphic as unfill or fill. 
o Select Auto Set, according to the nesting relationship of the selected 

graphics, it will be automatically set as unfill or fill. 
After setting, you can check the unfill and fill cut properties by switching Fill Mode. 

6.8 Kerf Compensation 
Laser cutting has a kerf (the part that is lost during cutting), which makes the size of the 
actual cut part deviate from the theoretical size of the part. This operation enable 
geometric compensation for deviations. 

Kerf compensation types are divided into: 

 All Shrink: Shrink the cutting area for all selected parts. 

 All Expand: Expand the cutting area for all selected parts. 

 Unfill: Shrink; Fill: Expand: shrink the cutting area for parts with unfill attribute, 
and expand the cutting area for parts with fill attribute. 

Prerequisite: 
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Before setting kerf compensation, make sure the following: 

 The text has been Convert Text to Graphic. 

 Non-dot, scan, self-intersecting, CoEdge graphics. 

 Closed graphic. 
Operation Steps: 

1. Select one or more graphics. 
2. Select any of the following methods to open the Kerf Compensation dialog box: 

o In the common toolbar, click . 
o In the menu bar, click Technics → Kerf Compensation. 

 
3. Set the compensation type. 
4. Set the inner and outer width. 
5. Check Apply to Unclose Figure as required. 
6. Click OK. 

The result of kerf compensation is as follows: 

 
Related Tasks: 

If you need to save the commonly used inner/outer width for direct call next time: 

1. Select Add in the Configuration drop down box, and the Configuration dialog box 
will pop-up: 
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2. Click Add, set the name in the Description column, and set the inner and outer 

widths in the Inner Width and Outer Width columns respectively. 
3. When you need to use it, select the name set in the Description column in the 

Configuration drop down box, and the system will automatically fill in the inner 
width and outer width. 

6.9 Bridge 
When a workpiece is composed of multiple parts, using this function to connect these parts 
can prevent it from falling apart after cutting and reduce the number of pierces. Multiple 
use of the Bridge function can achieve the effect of one stroke for all graphics, and it is 
mostly used for the connection of text strokes. 

Before setting the bridge, make sure the text has been Convert Text to Graphic. 

Operation Steps: 

1. Select the following method to open the Bridge dialog box: 
o In the common toolbar, click . 
o In the menu bar, click Technics → Bridge. 

 
2. Set the maximum space and width of the bridge, and click OK, the cursor changes 

to . 
3. Left click select both ends of the bridged part separately. 
4. Right lick or press Esc key to exit the bridge function. 
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The bridge effect diagram is as follows: 

 

6.10 Chamfer 
Perform arc chamfer on all corners smaller than 180° in the graphic to improve cutting 
effect on corners of thick material. 

6.10.1 Automatically Add Chamfer 
Automatically add chamfers to the selected objects that meet the conditions according to 
the set value. 

Operation Steps: 

1. Select the object. 
2. Select any of the following methods to open the Chamfer dialog box: 

o In the common toolbar, click . 
o Right click to call the shortcut menu, click Chamfer. 
o In the menu bar, click Technics → Chamfer. 

 
3. Set the range and radius of the chamfer. 
4. Optional: If the selected closed graphics will add chamfers according to the unfill 

and fill attributes, check Create Chamfer by Fill or Unfill. 
5. After setting, click OK, and the system will automatically add chamfers to corners 

that meet the conditions. 
The setting range is 45°~90°, and when Create Chamfer by Fill or Unfill is checked, the 
effect of automatically adding chamfers is as follows: 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 88 / 161 

 
6.10.2 Manually Add Chamfer 
The chamfer position can be selected by yourself. Corner range: 0°~180°. 

Operation Steps: 

1. Select any of the following methods to open the Chamfer dialog box: 
o In the common toolbar, click . 
o Right click to call the shortcut menu, click Chamfer. 
o In the menu bar, click Technics → Chamfer. 

 
2. Set the radius of the chamfer. 
3. Optional: Check Create Chamfer by Fill or Unfill. 

4. Click Set by Mouse, the cursor changes to . 
5. Left lick to select the position of the added point. 
6. Right click or press the Esc key to exit the function of manually add chamfers. 

When Create Chamfer by Fill or Unfill is not checked, the effect of manually adding 
chamfers is as follows: 
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6.11 Chop 
Divide the selected graphic into multiple blocks, that is, chop the machining waste to 
facilitate the waste to fall off. 

The object of chop needs to meet the following conditions: 

 Non-fill closed graphics other than text. 

 Large graphics, and the minimum distance between the chop line and the border of 
the primitive is 0.3mm, and the minimum length of the chop line is 1mm. 

 No micro joint added. 

 No other graphics are included. 
Operation Steps: 

1. Select the object. 
2. In the menu bar, click Technics → Chop to pop-up the Chop dialog box. 
3. Set the space and left side interval. The value range of left side interval: 0-1. 

The chop effect picture is as follows: 

 

6.12 Ring Cut 
Set the sharp corner of the overcut and rotate it to prevent overheat. 

Before setting ring cut, according to the actual situation set Unfill/Fill. 

Operation Steps: 

1. Select the object. 
2. In the menu bar, click Technics → Ring Cut, and the Ring Cut dialog box will pop-

up: 

 
3. Set the following parameters: 

o Angle: Range: 0°~90°. 
o Length: Range: 0.1mm~100mm. 
o Extend Length: Range: 0mm~5mm. 

The ring cut effect picture is as follows: 
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6.13 Release Angle 
It is used to cut out a fan-shaped area at the bending corner of a bent workpiece during 
bending process after machining, so as to solve the uplift of workpiece at the bending 
corner. 

Operation Steps: 

1. In the menu bar, click Technics → Release Angle to open the Release Angle 
dialog box: 

 
2. Set the range and radius of the release angle and click OK. The cursor change to 

. 
3. Left click to select where to add the point. 
4. Right click or press Esc key to exit the function of adding release angle. 

The effect diagram of adding release angle is as follows: 

 

6.14 Counterbore 
Counterbore technic, generate a set of counterbore auxiliary lines through parameter 
setting. Use the specific counterbore technic parameter machining auxiliary line to 
machine the counterbore on the primitive. 

Through the counterbore technic function, the section effect of the precious metal can be 
guaranteed, and the counterbore can be directly machined to avoid drilling and chamfering. 

Term: 

 Counterbore 
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Through hole with a chamfered slop, the counterbore accommodates the screw 
head when the screw is installed. Avoid screws protruding from the workpiece 
surface. 

 Counterbore auxiliary line 
In order to cut out the machining path of the counterbore, it cannot be directly 
selected for editing, but can only be adjusted by parameters. 

Operation Steps: 

1. Select the object. 
2. Select any of the following methods to open the Counterbore dialog box: 

o In the menu bar, click Technics → Counterbore, and the dialog box of 
Counterbore will pop-up. 

o Right click to call the shortcut menu, click Counterbore. 

 
3. Set parameters. 

Parameter diagram: 

 
 

Parameter Range Unit Description 

Turns [0, 100] - Total number of counterbore auxiliary lines 

Space [0, 100] Mm (metric: 
inch) 

Distance between counterbore auxiliary lines 

Spread direction 1.Shrink, 
2.Expand 

- The direction in which the counterbore auxiliary 
line expands compared to the original graphic 

Opposite to object 
direction 

- - The machining direction of the counterbore 
auxiliary line is opposite to the original graphic 

6.15 Instant Setting 
For the selected objects, add the same technic in batches to improve technic efficiency. 

Operation Steps: 
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1. Select the object. 
2. Select any of the following methods to open the Instant Setting dialog box: 

o In the common toolbar, click . 
o Right click to call the shortcut menu, and click Instant Setting. 
o In the menu bar, click Technics → Instant Setting. 

 
3. Set as needed. 
4. Click OK. 

6.16 Clear 
Delete the technic and machining track of the selected object, the machining technic that 
can be cleared includes: 

 Trajectory 

 Lead line 

 Kerf compensation 

 Micro joint 

 Chop 

 Round cut 

 Scan 

 Counterbore 
Operation Steps: 

1. Select one or more objects. 
2. Select any of the following methods to clear: 

o In the common toolbar, click  drop-down key to select items to be 
cleared. 

o Right click to call the shortcut menu, click Clear, and select items to be 
cleared. 

o In the menu bar, click Technics → Clear, and select the item to be cleared. 
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7 Layer Technic 
7.1 Overview 
The layer function is mainly used to set layer technic, that is, parameters such as cutting 
and piercing, to ensure the cutting effect. 

Select one of the following methods to open Layer Setting dialog box: 

 In the layer toolbar, click  Layer Setting. 

 In the menu bar, click Technics → Layer Setting. 
The Layer Setting dialog box is as follows: 

 
1. Layer selection box 

The system provides 7 color layers. Each layer can be set to different layer technic 
independently. By default, the layer technic of objects of the same color is the same. 
The following operations can be performed in the layer selection box: 

o Click layer: Set the layer technic of the target layer. 
o Select the target layer, select a layer in the Copy from XX drop-down box, 

copy and apply the layer parameters to the current layer. 
o Set Show All to ON status: The system displays all layers; otherwise, the 

system only show layers in the current tool path file. 
2. Parameter setting page 

After clicking the page switching button above, switch to the corresponding 
parameter setting page, including: 

o Film Cutting Process page 
Set the film cutting process under the global parameter layer here. 
For details, please see Set Film Cutting Param and Film Cutting Param. 

o Cut Param page 
Set the cutting and special technic under each layer here. 
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For details, please see Set Cutting Param and Cutting Param. 
o Piercing Param page 

Set the piercing technic parameter here. 
For details, please see Set Piercing Param and Piercing Param. 

o Accurate Machining page 
Set accurate machining technic parameter here. 
For details, please see Set Accurate Machining and Accurate Machining. 

3. Technic operation bar 
Add Technic Remark, Open/Save/Save As Technic. 

4. Unit setting bar 
According to the appropriate display unit need to be switched here. 

7.2 Operation 
Including the operations of specify and set layers and set layer technics. 

Follow these steps to perform layer operations: 

1. Set Film Cutting Param. 
2. Set Cutting Param. 
3. Set Piercing Param. 
4. Set Accurate Machining. 

After the operation is completed, in the technic operation bar Add Technic Remark, 
Open/Save/Save As Technic. 

7.2.1 Set Film Cutting Param 
Select the film cutting method to remove the protective film on the surface of the plate. 

Operation Steps: 

1. In the layer selection box on the layer setting page, click Global Params to switch 
to the Film Cutting Process page: 

 
2. Select the film cutting method. 

For details, please see Film Cutting Method. 
3. Set the parameters of Film Cutting Param. 

For details, please see Parameter Description. 
4. Optional: If need to maintain the common parameter Fixed Position for film cutting, 

check Fixed Film Cutting. 
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5. Optional: If need to keep the gas output port always ON during the film cutting 
process and film cutting to cutting process, check Gas ON after Film Cutting. 

7.2.2 Set Cut Param 
Set cut param, special technic and cutting power curve. 

By editing the power curve, problem such as over-burning around the corner and 
inconsistent cutting effects with different thicknesses can be solved in laser cutting. The 
cutting power can be adjusted so that it change with the cutting speed to ensure that the 
heat power absorbed within the unit area is consistent and achieve the ideal cutting effect. 

Operation Steps: 

1. In the layer setting page, click Cut Param of the non-global params layer to switch 
to the Cut Param page: 

 
2. Set the parameters of the Cut Param and Special Technic modules. 

For details, please see Cut Param. 
3. Check Enable Speed Power Adjust and Enable Speed Freq. Adjust. 

When cutting, the cutting power and frequency change with the cutting speed. The 
specific values are determined by the speed power and frequency curve; otherwise, 
the power and frequency remain unchanged during cutting. 

4. Taking Enable Speed Freq. Adjust as an example, click Edit to pop-up the Speed 
Power Curve Editing dialog box: 
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5. Select the following methods to edit the power curve: 
o Edit in the curve box: 

 Double click the target position to add a curve node. 
The more nodes to add, the more accurate the curve will be. 

 Double click the added node position to delete the curve node. 
Right list synchronously add or delete the corresponding speed and power 
values. 

o Edit in list: 
 Click Add. List auto add a set of speed and power values, double click 

to modify the value, and press Enter to confirm. 

Note: The speed power curve is an incremental curve, and the 
added values need to increase in sequence and 0 and 100 cannot be 
modified. 

 Select a set of speed and power values and click Delete to delete the 
set of values. 

The curve box on the left add or delete corresponding nodes simultaneously. 
To restore the curve to the default curve, click Clear. 

During the machining process, the system will automatically adjust the speed and 
power/frequency match relationship according to this curve, without the need for other 
manual operations. 

7.2.3 Set Piercing Param 
Select the piercing method and set the piercing parameters. 

Operation Steps: 

1. Click Piercing Param to switch to the Piercing Param page: 

 
2. Select the piercing method. 

For details, please see Piercing Method. 
3. Set piercing related parameters. 

For details, please see Piercing Parameter Description. 
4. Optional: If the piercing method is set to Gradual, set the parameter Increment S.. 
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The cutting head will descend to Cutting Height with Increment S.; otherwise the 
cutting head will follow to Cutting Height. 

5. Optional: Set the Extra Blow switch button to ON, and set the parameters below 
Extra Blow. 
After the piercing is completed, turn off the laser and perform blowing, otherwise 
there will be no extra blow after the piercing is completed. 

7.2.4 Set Accurate Machining 
Slowly start, slowly stop cutting technic. 

Operation Steps: 

1. Click Accurate Machining to switch to the Accurate Machining page: 

 
2. Check to enable the technic as needed and set the corresponding parameters. 

For details, please see Accurate Machining. 

7.2.5 Add Technic Remark 
Remark the machining information to facilitate the import/save as technic. The system 
automatically generate technic file name based on the remark information, thereby 
distinguishing technic files with different machining conditions. 

Naming rule: Laser power-Material-Thickness-Mach type-Cutting gas-Nozzle type-Aperture 

Operation Steps: 

1. In the Layer Setting dialog box, click the blue text after Technic Remark, and the 
Technic Info dialog box will pop-up: 

 
2. Set relevant parameters according to the actual situation and add notes. 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 98 / 161 

7.2.6 Open/Save/Save As Technic 
Open/save/save as technic files for each layer one by one. 

Naming rule: Layer name-Material-Thickness-Laser power-Mach type-Nozzle type-Aperture-Cutting gas-

Remarks 

Select the following operations as needed to open/save/save as the technic: 

 Click Open to open the technic folder, select the target LTPX format file, import and 
overwrite the technic of the current layer setting. The technic file name is displayed 
in the upper right corner of the layer setting interface. 

 Click Save technic: 
o If it is a new technic file, the Save Technic As dialog box will pop-up. After 

setting the parameters, select the save path and click Confirm. 
o If this technic file is opened, update files in the technic file folder. 

 Click Save As. After setting the parameters in the Save Technic As dialog box, 
select the save path and click Confirm. 

7.3 Parameter 

7.3.1 Film Cutting Param 
Include: 

 Film Cutting Method 

 Parameter Description 

7.3.1.1 Film Cutting Method 
Include: 

 Single Cut: Single graphic film cutting first, and the graphic is machined after film 
cutting. 

 Group Cut: Taking the group as a unit, film cutting the graphics of the whole group 
first, and then machining the graphics of the group. Other groups of graphics are 
also done in this order. 

 Global Cut: Check all graphics with film cutting layer according to film cutting 
parameter film cutting, and then normal machining. 

7.3.1.2 Parameter Description 
Include: 

 Pre Laser On: Delay before turning on the laser. 

 Post Laser On: After turning on the laser and continuing to set the time, go to the 
next step. 

 Pre Laser Off: Delay before turning off the laser. 

 Power: By adjusting the laser, set the laser intensity during film cutting. 

 Frequency: When film cutting the carrier frequency of the PWM modulation signal 
is also the number of times the light is emitted within one second. The larger the 
value, the more continuous the light is emitted. 

 Duty Ratio: Adjust the laser through PWM to set the duty ratio when film cutting. 

 Lift Height: When switching film cutting, the height of the laser head lifting. 

 Gas Type: The type of auxiliary gas used while film cutting. 

 Pressure: The pressure of the auxiliary gas during film cutting needs to be used in 
conjunction with proportional valve. 

 Focus: Take effect when focus control is enabled. The position of the focus point 
when film cutting. 

 Height: The height of the nozzle from the plate when film cutting. 
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 Speed: Actual film cutting speed. 

 Fixed Film Cutting: Maintain the parameter Fixed Height Position in the common 
parameter for film cutting. 

 Gas ON after Film Cutting: The gas output port is always ON during the film 
cutting process and film cutting to cutting process. 

 Pre-punch before Cutting Film: When using global film cutting, the default is to 
perform film cutting first and then prepiercing. If checked, perform prepiercing first 
and then film cutting. All other film cutting methods perform prepiercing first. 

 Auto Group Prepunch: By default, prepiercing start cutting after completing the 
global holes. After auto group, start cutting the primitives of this part after the group 
is completed. 

 Detect Piercing in Edge Sharing: When coedge primitives slowly start on the tool 
path that has been cut, auto detect will be performed and the piercing process will 
be omitted. 

 Inkjet Enable: The inkjet code function will take effect after registration. If not 
checked, the inkjet code function will disabled. 

 Connect Cut Enabled: After enabling it, when machining primitives connected end 
to end, piercing and other behaviors will no longer be performed at the start point of 
the second primitive. 

7.3.2 Cut Param 
Include: 

 Common Parameter 

 Special Parameter 

7.3.2.1 Common Parameter 
Include: 

 Pre Laser Off: Delay before turning off the laser. 

 Pre Laser On: Delay before turning on the laser. 

 Post Laser On: After turning on the laser and continuing to set the time, go to the 
next step. 

 Cut Speed: The actual cutting target speed when the feed rate is 100%. 

 Peak Power: Adjust the laser through analog quantity to set the laser intensity 
during cutting. 

 Cut Frequency: When cutting the carrier frequency of the PWM modulation signal 
is also the number of times the light is emitted within one second. The larger the 
value, the more continuous the light is emitted. 

 Duty Ratio: Adjust the laser through PWM to set the duty ratio when cutting. 

 Lift Height: When switching cutting graphics, the height of the laser head lifting. 

 Prepierce Up H: During the prepiercing process, each time one hole is pierced, the 
cutting head is lifted up. If the total number of piercing in the tool path is 1, this 
parameter will not take effect. 

 Cut Pressure: The pressure of auxiliary gas during cutting needs to be used in 
conjunction with the proportional valve. 

 Cut Gas: The type of auxiliary gas used while cutting. 

 Cut Height: The height of the nozzle from the plate when cutting. 

 Cut Focus: Take effect when focus control is enabled. The position of the focus 
point when cutting. 

7.3.2.2 Special Parameter 
Include: 
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 Ignore This Layer: Not machining all graphics in the current layer. 

 Gas Keeps On for This Layer: Not off the blowing port during machining the 
graphics in this layer. 

 G00 Gas Pressure: Check this column to set the pressure at G00. When enabled, 
this layer G00 will not gas off. 

 Side Blow at Pierce: When piercing, open the side blow port. 

 Side Blow at Cut: When cutting, open the side blow port. 

 Fixed Cut: Whether to enable fixed height cutting. That is, when cutting, whether to 
maintain the fixed Z-axis coordinates for cutting. 

 Film Cut: Enabled when cutting metal materials with surface coatings. 

 Pre-piercing: All machining objects in the current layer enable the prepiercing 
function, so that all tool paths are perforated in advance before actual machining. 

 Nozzle: Type and size of nozzle. 

 Micro Joint at High Speed: The laser is not turned on at the micro joint, and the 
cutting head continues to move without deceleration. 

7.3.3 Piercing Param 
Include: 

 Piercing Method 

 Piercing Parameter Description 

7.3.3.1 Piercing Method 
Include: 

 None 
The system automatically perform the following machining actions: 

a. Enable the follow-up valve and blow valve. 
b. After controlling the cutting head G00 to descend to Cutting Height, wait for 

the Blow Delay time set in Common Parameter. 
c. Turn on the laser valve and start cutting. 

 1st Seg./2nd Seg. 
The system automatically perform the following machining actions: 

a. Enable the follow-up valve and blow valve. 
b. After controlling the cutting head G00 to descend to Pierce Height, wait for 

Blow Delay time. 
c. Turn on the laser valve and start piercing for Pierce Delay. 
d. According to the piercing method, do the following: 

 Gradual: Do not turn off the laser valve, go down to Cutting Height at 
Increment S., and start cutting. 

 Segment: Turn off the laser valve, control the cutting head G00 to 
descend to Cutting Height, turn on the laser valve, and start cutting. 

7.3.3.2 Piercing Parameter Description 
Include: 

 Increment S.: Set the speed from pierce height fall to cutting height using 
increment piercing. 

 Peak Power: Adjust the laser through analog quantity to set the laser intensity 
during piercing. 

 Frequency: The carrier frequency of the PWM modulation signal is used for pierce, 
and a lower frequency is generally used for pierce, and pulse pierce is used to 
avoid blast hole. 
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 Duty Ratio: Adjust the laser through PWM to set the duty ratio during piercing. 

 Gas: Auxiliary gas used during piercing. 

 Press: The pressure of the auxiliary gas during piercing needs to be used in 
conjunction with the proportional valve. 

 Height: The height of the piercing position from the plate. 

 Focus: Effective after enabling focus control. The position of the focus point during 
piercing. 

 Punch Delay: The time when laser is turned on at the piercing height during 
gradual piercing and segment piercing. 

 Extra Blow: After each level of piercing, whether to turn off the laser and then 
perform blowing. 

 Extra Blow Height: The height of the extra blow. If the height value set by the 
parameter is less than the maximum height followed directly, it will follow directly to 
that position.If the height value set by the parameter is greater than the maximum 
height directly followed, the Z-axis first follow to a position 1mm away from the plate 
surface, and then use this as a datum increment to move to the height value set by 
the parameter. 

 Extra Blow Gas: Air, nitrogen, oxygen. 

 Press: The pressure value during blowing. 

 Blow Time: The interval time for blowing after turning off the laser. 

7.3.4 Accurate Machining 

 Enabled Slowly Start: Used when poor cutting occurs during the initial stage of 
thick plate cutting. If fine adjustment is not enabled, the effect is equivalent to the 
original slow start. 

 Enabled Slowly Stop: Used when dragging the end stage of thick plate cutting 
elements.If fine adjustment is not enabled, the effect is equivalent to the original 
speed. 

Fine adjustment technic at the start and end point of cutting can improve problems such as 
burn through, unable to cut through or over-burning slag. 

Note: Slowly start and slowly stop technic conflicts with the following three types of 
machining technic. 

 During flay cutting and high-speed micro-joint, slowly start and slowly stop technic 
not take effect. 

 When the lead line slowly drop to take effect, slowly start technic not take effect. 

 When slowly start and slowly stop technic take effect, the speed power adjustment 
not take effect. 
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8 Tool Path Arrange 
8.1 Sort 
It is used to specify the machining order of each graphics in the tool path file. You can find 

 in the common toolbar. All functions as shown in the picture. 

 
Sort strategy description: 

 Sort by Color: The graphics in the part are sorted again according to the sequence 
of layers, which is only applicable to parts with nesting relationship. 

 Allow Graphics Reverse when Sorting: In order to make the cutting path more 
coherent, it is allowed to automatically reverse the cutting direction of some 
graphics. 

 Sort by Identifying Contour: Distinguishes inner and outer membranes of 
graphics when sorting. 

 Small Graphics First Sorting: The small graphics whose size is smaller than the 
set value is sorted first, only applicable to parts with nesting relationship. 

 Outermost Layer is Overcast when Sorting: The default graphics outermost layer 
is unfill. 

 Sort within Group: The sorting of graphics in multiple combinations changes 
according to the sort strategy. 

If need displays the original machining sequence in the tool path, select any of the 
following methods to operate: 

 In the common toolbar, click  Show Order. 

 In the menu bar, click View → Show Order. 
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8.1.1 Auto Sort 
The system automatically arrange the machining sequence according to the selected sort 
strategy. 

8.1.1.1 Method 1 
Operation Steps: 

1. Optional: Selected objects if sorting only selected objects. 
2. Select any of the following methods to open the Sort dialog: 

o In the common toolbar, click . 

o In the common toolbar, click  drop-down box → Auto. 
o Right click to call the shortcut menu, click Mach Order → Auto Sorting. 
o In the menu bar, click Tool Path → Auto. 

 
3. Select sort strategy. 
4. Set advanced options, including: 

Option Description 

Divide grid Direction sort strategy.  

▪ Select Auto Set to automatically divide the sort distance according to the 
distance and number of all graphic direction sorted.  

▪ Select Fixed Value, input a fixed value interval, and when the interval between 
graphics is smaller than the set value, it will be divided into one area. 

Color The graphics in the part are sorted again according to the order of the layers, 
which is only applicable to the parts with nesting relationship. 
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Option Description 

Small objects first To sort objects whose sizes are less than the set value. It only applicable to part 
interior with nested relation. 

Sort in group To sort objects in groups according to the sort strategy. 

Allow reverse 
direction 

In order to make the cutting path more coherent, you can automatically reverse 
the cutting direction of some graphics. 

Auto set fill/unfill 
before sort 

After checking, the unfill/fill are automatically set when sorting. 

The outmost in 
inner contour 

After check the outermost layer of the graphics as unfill. 

Auto adjust start 
point 

After check to allow automatic modification of the start point. 

Hole part first After checking, the sort strategy acts on the inner membrane graphics first, and 
then on the outer membrane graphics. 

5. Click OK. 
Related Tasks: 

If need to individually set the sort of graphics within a single group, select any of the 
following methods to open the Sort dialog box and set the sort strategy and advanced 
options: 

 In the common toolbar, click  drop-down box → Sort within Group. 

 Right click to call the shortcut menu, click Sort within Group. 

8.1.1.2 Method 2 
Operation Steps: 

1. Optional: Selected objects if sorting only selected objects. 

2. In the common toolbar, click  drop-down box → select sort method: 

 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 105 / 161 

 

3. Click  drop-down box → select sort strategy: 

 
8.1.2 Manual Sort 
Manually specify the machining sequence for single or multiple objects. 

Operation Steps: 

1. Select any of the following methods to call the manual setting function: 

o In the common toolbar, click  drop-down box → Manual Sorting. 
o Right click to call the shortcut menu, click Mach Order → Manual Sorting. 
o In the menu bar, click Tool Path → Manual Sorting. 

The cursor becomes and automatically display the machining order. 
2. Select the target graphic to be set as the first one. 

The cursor becomes , the machining order on the object turns into 1, and the 
order of other objects turns into 2,3 ... in sequence on the basis of previous order. 
To reset the last order number, right click and select Previous Order. 

3. Repeat step 2 and click the objects in order. 
4. After manually changing the machining order, to exit Manual Sorting command, 

right click and select Exit, or press Esc. 

8.1.3 Specify the Single Workpiece Machining Order 
Manually specify the machining order of an object. 

Operation Steps: 

1. Select an object. 

2. In the common toolbar, click  drop-down box → Specify Separately 
dialog box: 
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3. Enter the specified sequence in the Number [1, n] input box. 

n is automatically displayed as the maximum value of the machining sequence in 
the current tool path file. 

8.1.4 Sort to the Top/Bottom 
Change the machining order of the selected single object to the top or the bottom. 

Operation Steps: 

1. Select an object. 

 In the common toolbar, click  drop-down box → Sort to the Top / Sort 
to the Bottom. 

 In the menu bar, click Tool Path → Manual Sorting → Sort to the Top / Sort to 
the Bottom. 

 Right click to call the shortcut menu, click Manual Sorting → Sort to the Top / 
Sort to the Bottom. 

8.2 Scan Cutting 
When the graphics to be cut are regular graphics and present a certain regular sort, the 
tool path is re-planned through scanning and cutting to find the most efficient path for 
machining. At the same time, it eliminate the lift and lower tool steps between graphics 
during ordinary laser cutting machining, and only control the on/off light during the 
movement. 

According to different cutting graphics, the scan cutting methods are divided into: 

 Line Scan: Identify objects as lines. 

 Arc Scan: Identify objects as arcs. 

 Runway Scan: Identify objects as a graphic similar to playground runway. 

 Ring Scan: Identify objects as nested ring graphic inner and outer. 

 Sector Scan: Identify objects as sector graphic. 

 LED Scan: Identify objects as graphic filled with small circles. 

8.2.1 Line Scan 
Operation Steps: 

1. Select multiple objects. 
2. Select the following method to open the Line Scan dialog box: 

o In the common toolbar, click . 

o In the common toolbar, click  drop-down box → Line Scan. 
o In the menu bar, click Tool Path → Scanning → Line Scan. 
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3. Select the slowly start position and set the following parameters: 

o Max Scan Space S: The distance between the two collinear graphics is 
greater than the maximum scan space set, and they are divided into two 
groups for scanning. 

o Collinear Tolerance T: If the distance between two parallel lines in objects 
is less than the set value, the two lines are regarded as collinear. 

4. Check Sort after Scan as needed. 
The effect diagram of line scan is as follows: 

 
8.2.2 Arc Scan 
Operation Steps: 

1. Select multiple objects. 
2. Select the following method to open the Arc Scan dialog box: 

o In the common toolbar, click  drop-down box → Arc Scan. 
o In the menu bar, click Tool Path → Scanning → Arc Scan. 
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3. Optional: If need to scan the selected circle according to the sort strategy, check 
Sort and select the sort strategy. 

The effect diagram of arc scan is as follows: 

 
8.2.3 LED Scan 
Operation Steps: 

1. Select multiple objects. 
2. Select any of the following methods to open the Scan LED on Text dialog box: 

o In the common toolbar, click  drop-down box → LED Scan. 
o In the menu bar, click Tool Path → Scanning → LED Scan. 

 
3. Set inside and border sort: 

o Inside Sort: To sort all circles in the inner of the target objects, and form a 
scanning group. 

o Border Sort: Sort between advertise words. 
The effect diagram of LED scan is as follows: 
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8.2.4 Runway Scan 
Operation Steps: 

1. Select multiple objects. 
2. Select any of the following options to open the Runway Scan dialog: 

o In the common toolbar, click  drop-down box → Runway Scan. 
o In the menu bar, click Tool Path → Scanning → Runway Scan. 

 
3. Set the following parameters: 

o Angle Tolerance A: If the angle difference is less than the set tolerance, the 
target objects are parallel. Range: 0°~5°. 

o Size Tolerance R: If the height difference between two runways is less than 
the set tolerance, the sizes of target objects are the same. Range: 
0mm~1mm. 

The effect diagram of runway scan is as follows: 
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8.2.5 Sector Scan 
Operation Steps: 

1. Select multiple objects. 
2. Select any of the following methods to open the Sector Scan dialog box: 

o In the common toolbar, click  drop-down box → Sector Scan. 
o In the menu bar, click Tool Path → Scanning → Sector Scan. 

 
3. Set the following parameters: 

o Center Tolerance N: If the distance between circle centers of two circular 
rings is less than the set tolerance, the target objects are in a scanning group. 

o Radius Tolerance R: If the radius difference between two circular rings is 
less than the set tolerance, the target objects are in a scanning group. 

The effect diagram of sector scan is as follows: 

 
8.2.6 Ring Scan 
Operation Steps: 

1. Select multiple objects. 
2. Select any of the following methods to open the Ring Scan dialog: 
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o In the common toolbar, click  drop-down box → Ring Scan. 
o In the menu bar, click Tool Path → Scanning → Ring Scan. 

 
3. Optional: If need to scan the selected ring according to the sort strategy, check 

Sort, and select the sort strategy. 
4. Click OK, the system scans automatically. 

The effect diagram of ring scan is as follows: 
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9 Nest 
Nest function is used to arrange the given parts on the plate reasonably. The number of 
optimization parameters are provided for adjustment during layout, such as part space, 
sheet margin, rotation strategy, rotation angle, efficiency/utilization, etc. 

It is based on the principle of part nesting priority and material utility maximization, Nest 
function can achieve the following: 

 Nest a kind of parts or several kinds of parts. 

 Nest a kind of parts over the whole sheet. 

 Preview the nesting effect and analyze nesting results. Including plate usage rate 
and waste distribution, etc. 

 Fill the round holes in the advertise words. 

If need to generate nest report, click Machining → Nest Report in the menu bar. 

Prerequisite: 

Before nesting, make sure the USB dongle has been successfully inserted into the host, or 
imported an authorized file. 

9.1 Nest Sidebar 

In the common toolbar, click  to open/close the Nest Sidebar: 

 
 Parts: Display parts as thumbnail. 

o Click on the part to modify the name, total and machined quantity. 
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o Double click the part to display the part in the drawing area, and it can be 
modified. 

o After selecting the part, right click to modify part information, delete, export 
and import parts. 

 
 Plates: Display plates as thumbnail. 

o Click on the part to modify the plate name, total and used quantity. 
o Double click the plate to display the plate in the drawing area. 
o After selecting a plate, right click to modify the plate information, delete, 

export, import, and add rectangular plate. 

 
 Nest result: Display nest results as thumbnail. 

o Click the nest result to modify the name and the number of nest machined. 
o Double click the nest result to display the nest result in the drawing area. 
o After selecting the nest result, right click to new, delete, and export the nest 

result. 
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9.2 Part Nest 
Nest the parts in the current tool path, and edit the quantity, residual material type and 
rotation angle of the nested parts. 

Before setting nest, make sure that the parts and plates added to the list are closed 
graphics. 

Operation Steps: 

1. Optional: If the parts list does not have the required part, add the part or plate to 
the parts/plates list: 

o Select any of the following methods to import parts/plates: 

 In the common toolbar, click , click on the pop-up Nest 

Sidebar  Import → Import Part / Import Plate. 
 In the menu bar, click Nest → Import Part / Import Plate. 

Supported part and plate file formats for import include: dxf, dwg, ncex and lxd. 
o In the drawing area, select the drawn graphics and add: 

 Right click to call the shortcut menu, click Add to Part List / Add to 
Plate List to edit the quantity of parts and plates. 

 In the menu bar, click Nest → Add to Part List / Add to Plate List to 
edit the quantity of parts and plates. 

After clicking OK, the Nest Sidebar will pop-up automatically. 
If need to view the added parts or plates, double click the target parts or plates in 
the list to display them in the drawing area. 

2. Optional: If need to select the machining part/plate, check the check box in front of 
the part/plate in the list. 
Otherwise all parts/plates in the nest list are defaulted. 

3. Select any of the following options to open the Nest dialog box: 

o Click  Nest in the Nest Sidebar. 

o In the common toolbar, click  drop-down key → Nest. 

o In the menu bar, click Nest → Do Nesting. 
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4. In the Part Selection area, select all parts or checked parts in the machining parts 
list. 

Note: If no parts are checked in Nesting Sidebar, the checked parts here are gray 
and cannot be checked. 

5. In the Plate Selection area, set the plate information. 
o If you select all the plates in the plate list or check the plates, you can set the 

material and thickness of the plates. 
o If you select the standard plate, you can set the width, length, material and 

thickness of the plate. 
6. In the Nest Parameters area, set the nest parameter information. The parameters 

are described as follows: 
Parameter Description 

Plate Margin The distance between the part and the edge of the sheet. 

Part Space Distance between parts. 

Rotate Strategy The system provides 9 rotation strategies. Among them, the Intelligent 
Strategy system automatically specifies the optimal rotation angle, and the 
Specified Angle strategy can freely set the rotate angle. 

Rotate Angle If Intelligent Strategy or Specified Angle is selected for Rotate Strategy, 
you can customize the rotate angle. 

Start Pos Select the top left, bottom left, top right, and bottom right position to start 
nesting. 

Direction Select the direction of nest horizontal or vertical. 

Efficiency/Utilization Slide Efficiency/Utilization to choose to focus on time efficiency or 
material utilization. 

Nesting in Part Hole  The inner hole belongs to the waste area. To nest a single part into the 
inner hole of the nested graphics, check Nesting in Part Hole. 

7. In the Post-processing area. The parameters are described as follows. 
Parameter Description 

CoEdge: Check CoEdge: and select the CoEdge method, you can click CoEdge Params to 
view and modify the CoEdge parameters. For details, please see CoEdge. 

All CoEdge All CoEdges. 

Only Line 
CoEdge 

The sides of the line of the part share the same side, and the sides of the curve do not 
share the same side. 

Minimum 
CoEdge 
Length 

Lines smaller than Minimum Coedge Length will not be shared with other lines during 
nesting. 

CoEdge Part 
Number 

The maximum of several parts are allowed to share edges. 

Sort After selecting Sort, the results after nesting will be automatically sorted according to 
the sort strategy set last time. Click Sort Params to view and modify the sort strategy. 
For details, please see Auto Sort. 

8. In the Remnant area, check Generate Remnant. Choose the right remnant type 
(rectangle, T, L) to maximize material savings. 

9. Optional: Check Clear Previous Nest Results to clear the current nest list and 
output new nest results. 
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10. After the setting is complete, click OK, the system will automatically nest and 
display the nest results. 

 
The nest result column in the left show the number of parts, utilization rate and 
machined times. 
If you need to edit graphics, you can make adjustment in the drawing area. 

9.2.1 One Key Nesting 
The shortcut for nesting, simplifying the operation steps. Nested parts cannot be edited 
individually. 

Operation Steps: 

1. In the parts list or drawing area, select the target object. 
2. Select any of the following methods to open the Fast One Key Nest dialog box: 

o In the common toolbar, click  drop-down key → One Key 
Nesting. 

o In the menu bar, click Nest → One Key Nesting. 

 
3. In the Plate Param area, set the width, length, material and thickness of the plate. 
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4. In the Nest Param area, set the nest parameter information. The parameters are 
described as follows: 

Parameter Description 

Part Distance Distance between parts. 

Plate Edge The distance between the part and the edge of the sheet. 

Rotate Strategy The system provides 9 rotation strategies. Among them, the Intelligent 
Strategy system automatically specifies the optimal rotation angle, and the 
Specified Angle strategy can freely set the rotate angle. 

Rotate Angle If Intelligent Strategy or Specified Angle is selected for Rotate Strategy, 
you can customize the rotate angle. 

Start Position Select the top left, bottom left, top right, and bottom right position to start 
nesting. 

Direction Select the direction of nest horizontal or vertical. 

Efficiency/Utilization Slide Efficiency/Utilization to choose to focus on time efficiency or material 
utilization. 

Nesting in Part Hole The inner hole belongs to the waste area. To nest a single part into the inner 
hole of the nested graphics, check Nesting in Part Hole. 

5. After the setting is complete, click OK, the system will automatically make nest and 
display Nest Result. 
If you need to edit graphics, you can make adjustments in the drawing area. 

9.2.2 Bestrew Nest 
It is mainly used for bestrew page cutting of the single graphic. The software quickly 
covers the whole plate according to the selected parts, set parameters and plate. 

Operation Steps: 

1. Select the graphic in the drawing area. 

2. In the common toolbar, click  drop-down key → Bestre Nesting. 

 
3. In the Plate Param area, set the length and width of the plate. 
4. In the Nest Param area, set the following parameters: 

Parameter Description 

Plate Edge The distance between the part and the edge of the sheet. 

Part 
Distance 

Distance between parts. 
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Parameter Description 

Rotate 
Strategy 

The system provides 9 rotation strategies. Among them: 

▪ Intelligent Strategy system automatically specifies the optimal rotation angle. 

▪ Specified Angle strategy can freely set the rotate angle. 

Rotate Angle If Intelligent Strategy or Specified Angle is selected for Rotate Strategy, you can 
customize the rotate angle. 

5. After the setting is complete, click OK, the system will automatically make nest and 
display nest result. 
If you need to edit graphics, you can make adjustments in the drawing area. 

9.3 Advertise Words Fill 
It is commonly used to fill circle holes in advertising board graphics. The circle holes are 
evenly and orderly arranged in the advertise word. 

9.3.1 Circle Fill 
Distribute circle holes evenly in the middle of the element according to the set parameters, 
and effectively reduce the number of light holes arranged. It is recommended to set the 
circle spacing to be more than 3 times the circle radius, which is suitable for most fonts. 

Operation Steps: 

 Manual fill 
a. In the menu bar, click Nest → Advertise Words Fill → Circle Fill, and the 

Circle Fill dialog box will pop-up: 

 
b. Set Public Param. 
c. Click Manual Fill to automatically close the Circle Fill dialog box, and the 

cursor changes to . 

Note: The big white circle of the cursor is a circle with circle spacing added, 
which makes it easier to control the distance from the surrounding circle 
during manual fill. 

d. Click the target position to generate circle hole. 
e. Right click or press ESC to exit. 

 Auto fill 
a. Select the object to be filled. 
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b. In the menu bar, click Nest → Advertise Words Fill → Circle Fill, and the 
Circle Fill dialog box will pop-up: 

 
c. Select fill method: 

Method Description 

Well-
distributed 

To well distribute circles in the object so as to effectively reduce circles. It is appropriate 
for the irregular fonts. 

Ring According to the set parameters, the system shrinks the graphics layer by layer and fills 
the circle holes on the shrink contour lines. 

Rectangle According to the set parameters and the external frame of the selected graphic, the 
system automatically divide the external rectangle of the graphic into a single small 
rectangular frame, and place the circle hole in the center of the small rectangular frame. 

Edge According to the set parameters, the system fill the circle holes along the edge. Space 
gaps are manually filled with circle holes. Suitable for narrower fonts. 

Horizontal To arrange circles on the line that is parallel with X-axis, so as to make circle centers of 
each row are on the same horizontal line. Suitable for founder fonts or graphics. 

Vertical To arrange circles on the line that is parallel with Y-axis, so as to make circle centers of 
each row are on the same vertical line. Suitable for founder fonts or graphics. 

d. Set public parameter and policy parameter. 
e. Click Auto Fill. 

9.3.2 Check Circle Quantity 
Used to count the quantity and size of circle holes. 

Operation Steps: 

1. In the menu bar, click Nest → Advertise Words Fill → Circle Check. The cursor 

becomes . 
2. Select the target region. The result shows in Circle Num Check dialog box: 
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3. Right click or press ESC to exit. 

9.3.3 Circle Adjust 
It is used to change the distribution of certain circles, so as to solve the problem that the 
circles cannot be filled in certain regions or its filling effect is not good. 

Operation Steps: 

1. In the menu bar, click Nest → Advertise Words Fill → Circle Adjust. 
2. Set Edge Distance and Circle Distance. 

 

3. Click OK, the cursor becomes to . 
4. Select the target region. 

The system automatically deletes circles in the target region and according to the 
set Edge Distance and Circle Distance, use rectangle filling to fill the circle hole in 
this area. 

5. Right click or press ESC to exit. 

9.3.4 Circle Erase 
It is used to delete redundant circles in the objects. 

Operation Steps: 

1. In the menu bar, click Nest → Advertise Words Fill → Circle Erase. The cursor 

becomes . 
2. Select the target area with a frame to erase the circle holes in the graphic. 
3. Right click or press ESC to exit. 
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10 Machining Operation 
10.1 Run Report 
Generate machining statistics report to view the number, cutting length, cutting time, 
piercing quantity and piercing time of each type of parts produced by each machining, as 
well as charging for machining, etc., to reflect the results of machining. 

Before checking machining information statistics, make sure that the target tool path file 
has been machined at least once. 

Operation Steps: 

1. Select the following method to open the Report dialog box: 
o In the run report column, click Report. 

o In the menu bar, click Machining → Report. 

 
2. Check statistics information. 

o Merge: Merge the same machining files. 
o Filter: Filter files based on start/end time. 
o Show all: Display all machining reports, that is, merge and filter hidden data 

to display. 
3. Check the target item. According to need, do the following: 

o Charge: Click Charge, enter each unit price, click Calculate, and the system 
will automatically calculate the total cutting cost. 

If modify the charge method and unit, click Machining→ Price Setting in the 

menu bar. 
o Output report: Click Report Preview to generate a report for each statistics 

information, and you can export a .pdf file. 
o Export: Click Export, and in the pop-up dialog box, perform operations as 

required: 
 Export the running report of the checked items: Select Manual, set the 

export path, and click Export. 
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 Enable auto export running report function: Select Auto, set the 
export path, and click Apply. 

 

10.2 Production Report 
Before machining, charge each statistics information or machining can estimate the 
number of pierce, length, time and cost before actual machining. 

Operation Steps: 

1. Optional: If you need to charge for machining, you need to set the machining unit 
price. 

a. In the menu bar, click Machining → Price Setting. 

b. Set the billing method, unit and unit price. 
c. Click Confirm. 

2. According to the objects that need to generate reports are different, select to 
perform the following operations. 

o Generate production reports for all objects in the drawing area. 

a. In the menu bar, click Machining → Production Report. 

b. Enter material and display information, click Confirm. 
o Generate production reports for selected target objects. 

a. In the drawing area, select the target object. 

b. Click  in the machine control bar. 

c. In the menu bar, click Machining → Production Report. 

d. Enter material and display information, click Confirm. 

Note: If the object is not selected in the drawing area, but  is clicked in the 
machine tool control bar, the production report cannot be generated. 

10.3 Nest Report 
The nest report can be generated for the nest results in the nest result list. Charge each 
statistics information or machining can estimate the number of pierce, length, time and 
cost before actual machining. Among them, part graphics and names are generated to 
facilitate users to identify parts and sort materials after machining. 

Operation Steps: 

1. Optional: If you need to charge for machining, you need to set the machining unit 
price. 

a. In the menu bar, click Machining → Price Setting. 

b. Set the billing method, unit and unit price. 
c. Click Confirm. 
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2. In the menu bar, click Machining → Nest Report. 

3. Set the material information and the information displayed in the report, click 
Confirm to generate the report. 

4. Support to save as PDF format export or print directly. 

10.4 Count Setting 
Used to count machining quantities. 

Operation Steps: 

1. In the machining information statistics column, click Count Setting to open the 
Count Setting dialog box: 

  
2. After checking Enable Counting, set planned, finished, and end actions according 

to the actual situation. 
3. Optional: If you need to automatically clear the machined number when changing 

the machining file. Check Automatically Clear the Completed Count after File 
Name Changes. 

The system automatically count according to the following rules: 

 After the file is completely machined, the count plus one. 

 If stopped during machining, the count plus one will occur after the breakpoint 
resume and complete whole machining. 

10.5 Lubricate Screw 
After the machine tool has been running for a period of time, the screw need to be 
lubricated. 

Select the following methods to lubricate screw: 

 Auto Lubricate Screw: Perform lubricate during the auto machining according to the 
set system parameters. 

 Manual Lubricate Screw: Manually control the machine tool to perform lubricate. 

10.5.1 Auto Lubricate Screw 
Operation Steps: 

1. In the menu bar, click System → System Parameters → External Device → 3.1 

Lubricate to set the parameter Lube Type: 
o 0: None 
o 1: Auto lube (time) 
o 2: Auto lube (dist.) 
o 3: Auto lube (software start) 

2. According to the selected lubricate type, set the following parameters: 
o Auto Lube Duration 
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o Auto Lube Interval: Set when the lubricate type is Auto Lube (Time). 
o Auto Lube Dist.: Set when the lubricate type is Auto Lube (Dist.). 
o Enable Lube Pressure Detection 
o Lube Pressure Detection Delay 

After setting, the system Auto Lube Interval/Auto Lube Dist./automatically open the 
lubricate port for Auto Lube Duration. 

10.5.2 Manual Lubricate Screw 
Operation Steps: 

1. In the menu bar, click Machining → Lubricate to open the Lubricate dialog box: 

 
2. After setting the corresponding parameters, click Start. The system start to perform 

the lubricate action. 

10.6 Jiggle Y1Y2 Axis 
Joggle Y1-axis and Y2-axis provide independent, quantitative control of the Y1-axis and 
Y2-axis. According to the actual synchronization deviation of Y1-axis and Y2-axis, adjust 
the feedback coordinates of Y1-axis and Y2-axis to be consistent to complete manual 
correction. 

Operation Steps: 

1. In the menu bar, click Machining → Gantry Axes Jiggle to open the Gantry Axes 

Jiggle dialog box: 

 
2. Turn Enable Gantry Axes Correction to ON status. 
3. Select the step length 0.01mm, 0.1mm, 1mm or click the input box to customize the 

step value (default value 5mm). 
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4. Click Y1+ / Y1- / Y2+ / Y2- to adjust the feedback coordinates of the Y1-axis or Y2-
axis. 

10.7 Cut Sheet 
The function of cut sheet is to whole sheet horizontal cutting. It is mainly used to cut off 
excess waste materials to generate remain materials, or cut long sheets to appropriate 
size. 

10.7.1 Cut Sheet Mode 
The cut sheet function has two modes: thin and coarse, depending on the material and 
thickness of the sheet to be cut. Only the cut sheet action process is different between the 
two modes. The remaining setting methods are consistent. 

 Thin: Thin mode is mainly used for no need pierce and can directly cut through 
thinner sheet. Thin start from the current point. Cut half of the sheet first, then return 
to the start point to complete remain half. 

 
 Coarse: Coarse mode is mainly used for not add pierce technic. Directly cut sheets 

that cannot be cut through. Coarse edge find to one side first, and then light cut 
start from outside the sheet edge to complete the cutting. 

 
10.7.2 Function Entry 

In the software operation bar, click  Cut Sheet to pop-up the cut sheet function 
interface. 
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10.7.3 Cut Sheet Action Introduction 

10.7.3.1 Thin Mode 
The thin cut sheet action is a double-sided cut sheet action. The action flow is as follows: 

 
The cut sheet direction take the X-axis from Positive to Negative as an example (the 
picture above is the cut sheet diagram with the X-axis from positive to negative), and its 
motion track is along the direction parallel to the X-axis: 

1. First, cut the cut sheet along the positive direction of the X-axis at the current point. 
2. When cutting to the sheet edge, the Z-axis lift up and return to the start point of 

cutting. 
3. Continue to cut sheet in the opposite direction to the first cut (negative direction of 

the X-axis). 
4. After cutting in reverse to out margin, lift the cut sheet on the Z-axis to end. 

10.7.3.2 Coarse Mode 
The coarse cut sheet action is divided into three steps: edge finding, fixed height cutting, 
and follow-up cutting. The specific cut sheet process is as follows: 
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1. Start to cut sheet, and at 0 point (current point) the cutting head follow the sheet to 

edge finding in the direction opposite to the set direction. 
2. After finding the boundary, the cutting head return to the position One Click Cut 

Board Fixed Height Distance from the boundary. 
3. Move the fixed height position to the emit light point (outside the boundary, 

Distance from Boundary + One Key Outside the Cut Sheet) and start lighting (b 
point: cut sheet start point). 

4. After the light is emitted, the cutting head cut at the set fixed height One Click Cut 
Board Out Distance + One Click Cut Board Fixed Height Distance distance (the 
distance from b point to c point is the fixed height cutting distance). 

5. After cutting out margin along the set cutting direction, lift the Z-axis and the cut 
sheet ends. 

A series of related system parameters are used in the coarse cut sheet. For details, please 
see Cut Sheet System Parameter. 

10.7.3.2.1 Double-sided Edge Finding 
In the cut sheet interface, you can check the Double-sided Finding function when select 
the coarse mode. This function is mainly used to prevent the cutting head from downward 
after advance lift or out margin at the end of the cut sheet. 

When Double-sided Finding is checked, the action process of coarse cut sheet is divided 
into two types: one cut and two cut. 

Distinguished by the value of the system parameter Double-sided Edge Finding 
Strategy: 

 When the parameter value is set to Yes, the cutting strategy is Double-sided 
Finding and One Cut; 

 When the parameter value is set to No, the cutting strategy is Double-sided 
Finding and Two Cut. 
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10.7.3.2.1.1 One Cut 
Take the "X-axis from negative to positive" direction as an example: 

 
1. Start edge finding. The cutting head follow the sheet surface at the current position 

(O point), and first performs edge finding in the same direction as the set cut sheet 
direction (direction 2). After finding the edge (e point), the cutting head is lifted and 
moved to the edge finding start point (O point), and then followed again until the 
sheet surface face the direction opposite to the first edge finding (direction 1) and 
the next edge finding is performed. 

2. After the edge search is completed, the cutting head returns to the position (c point) 
of One Click Cut Board Fixed Height Distance from the boundary. 

3. Move the fixed height position to the position of emit light point (a point) (outside the 
boundary, Distance from Boundary + One Click Cut Board Out Distance) and 
start emit light for fixed height cutting. 

4. After the light is emitted, the cutting head cuts along the set cutting direction at the 
set fixed height One Click Cut Board Out Distance + One Click Cut Board Fixed 
Height Distance distance (a point to c point). 

5. After the fixed height cutting is completed, the cutting head start follow-up at the 
follow-up start point (c point) and continues cutting at the follow-up height until it 
reach the position (d point) of One Click Cut Board Fixed Height Distance from 
the other side of the sheet. Then retrace distance the Coarse Cut Retrace 
Distance During Double-sided Edge Finding at a fixed height to cut to the follow-
up turn fixed height retrace point (g point). 

6. Continue cutting at a fixed height. After fixed height cut the length for Coarse Cut 
Retrace Distance During Double-sided Edge Finding + One Click Cut Board 
Fixed Height Distance + One Click Cut Board Out Distance (g point to f point), 
the system turn off the light and Z-axis lift. 

7. Cut sheet ends. 

10.7.3.2.1.2 Two Cut 
Take the "X-axis from negative to positive" direction as an example: 
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1. Start edge finding. The cutting head perform edge finding along direction 1 at O 

point. 
2. After the edge find is completed, the cutting head return to the position (j point) of 

One Click Cut Board Fixed Height Distance from the boundary. 
3. Move the fixed height position to the position of emit light point (c point) (outside the 

boundary, Distance from Boundary + One Click Cut Board Out Distance) and 
start emit light for fixed height cutting. 

4. After the light is emitted, the cutting head cut along the same direction as the set 
cutting direction at the set fixed height One Click Cut Board Out Distance + One 
Click Cut Board Fixed Height Distance (c point to a point) distance. 

5. After the fixed height cutting distance is completed, the cutting head start follow-up 
resume cutting at the follow-up start point (a point). When cutting to the edge finding 
start point (O point), turn off light and turn off follow-up. 

6. Turn on follow-up again at O point and perform edge finding again in the same 
direction as the set cut sheet direction (direction 2). 

7. After the edge find is completed, the cutting head return to the position (d point) of 
One Click Cut Board Fixed Height Distance from the boundary. 

8. Move the fixed height position to the position of emit light point (f point) (outside the 
boundary, Distance from Boundary + One Click Cut Board Out Distance) and 
start to emit light and blow. 

9. After the light is emitted, the cutting head cut along the opposite direction as the set 
cutting direction at the set fixed height One Click Cut Board Out Distance + One 
Click Cut Board Fixed Height Distance distance (f point to d point). 

10. After the fixed height cutting distance is completed, the cutting head start follow-up 
resume cutting at the follow-up start point (d point). When cutting to the edge finding 
start point (O point), turn off light and turn off follow-up. 

10.7.4 Cut Params 

10.7.4.1 Cut Sheet Technic 
For the technic of cutting sheet, select the corresponding layer in the parameter Cut Layer 
of the one key cut sheet function. 
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The layer in the parameters refer to the technic parameters in the cutting layer, that is, the 
technic parameters we set in the corresponding cutting layer will be applied when actually 
cut sheet. 

10.7.4.2 Cut Sheet Speed 
There are two setting methods for cut sheet speed: 

 
 If Cut Spd is unchecked, the cutting speed in the layer parameters we selected will 

be used for cutting when cut sheet. 

 If Cut Spd is checked, the speed set in the bar after the check option will be used 
for cutting when cut sheet. 

10.7.4.3 Cut Sheet Direction 
Take the position of the cutting head as the start point, the cutting direction is the cut sheet 
direction. 

Cut sheet is divided into four directions: X-axis from negative to positive, X-axis from 
positive to negative, Y-axis from positive to negative, and Y-axis from negative to positive. 
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10.7.4.4 Safe Position 
The safe position applies to both positive and negative limit ends. The definition of the safe 
position is the distance between the artificially set sheet boundary and the soft limit. When 
cutting sheet, if the cutting position reach the safe position and the out margin signal is not 
detected, the system will consider that the boundary has been cut and will not continue 
cutting, and then perform the next step. At this time, the system will give the following 
prompt: The target point movement failed, possible reasons: 1. The movement is limited 2. 
No signal is obtained!. 

 
Take thin cutting, the X-axis safety position is 10 as an example. If the out margin signal is 
not detected when the first cutting is 10mm away from the soft limit, then the cutting head 
will directly light off and lift. Then move to the cutting start point in the opposite direction to 
continue cutting. During cutting in the opposite direction, when the out margin signal is not 
detected until the other side cutting is 10mm away from the soft limit, the system stop cut 
sheet and lift the cutting head. 

Note: Before arrival the safe position during the cut sheet process, if the out margin signal 
is detected at any point, the current action will end normally. 

10.7.4.5 Cut Sheet System Parameter 

Setting position of cut sheet system parameters: System Parameters → Advanced 

Function → 4.7 Other Param → 4.7.3 Cut Sheet. 
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Parameter Description 

One click cut board out 
distance 

When cutting thick sheet, the distance between the start point of emit light 
cutting and the edge of the sheet. 

One click cut board 
fixed cut height 

Fixed height when coarse cutting sheet, fixed height of cutting head in cutting 
stage. 

One click cut board 
flatness tolerance 

Used to adjust the sensitivity of out margin detection. The smaller the setting, 
the higher the sensitivity, the easier to detect out margin signal. 

One click cut board 
fixed cut distance 

Coarse mode fixed height cutting process, distance within the sheet. 

One click cut board 
fixed height distance 

In coarse mode, the position of the fixed height out margin point in the sheet 
from the edge of the sheet after edge finding is completed. 

One click cut board 
double edge find 
strategy 

Select the cutting method after double-sided edge finding: 

Yes: One cut; No: Two cut 

One click cut board 
over cutting distance 

Coarse cut sheet use double-sided edge finding, the retract distance when 
the edge of the sheet change from follow-up to fixed height during the one cut 
cutting strategy. 
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11 Advanced Operation 
11.1 Set Cycle Machining 
Set the times and interval times of cycle machining, and check the current machined times. 

Cycle machining is suitable for formal machining and dry run. 

Operation Steps: 

1. In the menu bar, click Advanced → Cycle Machining to open the Cycle 

Machining dialog box: 

 
2. After checking Enable, set the cycle times and interval time. 

The system automatically count according to the following rules and fill the results into the 
Dones input box, display the current machining times in real time: 

 If pause or stop machining before not arrival the set cycle times, this indicate the 
current actual cycle times. 

 Program complete execute count as one cycle. 
After the machining is completed and the set times are needed, if need to clear the 
machined times, click Clear. 

11.2 Nozzle Information Management 
Configure the nozzle type and aperture for configuration when setting the layer technic. 

Operation Steps: 

 Check nozzle information 

a. In the menu bar, click Advanced → Nozzle Info. Management to open the 

Nozzle Info. Management page. 
b. In the drop-down key of the Nozzle Type area, select the nozzle type. The 

corresponding nozzle information is displayed on the left according to the 
nozzle type. 
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 Add nozzle 
a. In the drop-down key of the Nozzle Type area, select the nozzle type to be 

added. 
Note: If there is no suitable nozzle type, you need to add a new nozzle type: 

click , in the pop-up Nozzle Information dialog box, fill in the nozzle 
abbreviation and name, and click OK. 

b. Fill in the Nozzle Dia information. 
c. Click Add. 

 Delete nozzle information 
a. Select the nozzle information to highlight it. 
b. Click Delete. 

 Save nozzle information 
a. Click Confirm to save and close the dialog box. 

Note: Since the dialog box will close after click Confirm, it is recommended to click 
Confirm after complete add and delete operations. 

If save is not needed, click the Cancel or  to close button. 

11.3 Manage Material 
Add or delete material 

Operation Steps: 

 Add material 

a. Click Advanced → Material Info Management in the menu bar to pop-up 

the Manage Material dialog box: 

 
b. Click the Name and Shorthand input boxes respectively and enter name 

and shorthand. 

c. Click Add → Confirm to add material. 

 Delete material 
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a. Click Advanced → Material Info Management in the menu bar to pop-up 

the Manage Material dialog box: 
b. Click to select the target material to highlight it. 

c. Click Delete → Confirm to delete material. 

11.4 Focus Control 
Cutting different sheets has different focus requirements; different focus requirements are 
also required to ensure machining quality when piercing and cutting. The Focus Control 
function is used to automatically adjust the focus during machining. 

In the actual machining process, set the cutting parameter Cut Focus or piercing param 
Focus in the Layer Setting dialog box to use this function. 

Operation Steps: 

1. Enable focus control function. 

a. In the menu bar, click System → System Parameters to open the System 

Parameters page. 
b. In the parameter tree on the left, select manufacturer permissions, select the 

node Overview → External Device → 3.5 Focus Control → 3.5.1 General 

Parameters, and set the parameter Enable Focus Control to Yes. Enable 
focus control and restart for the setting to take effect. 

2. Adjust focus before machining. 

a. In the menu bar, click Advanced → Focus Control to pop-up the Focus 

Control dialog box: 

 
b. Check Parameter Setting and set the corresponding parameters. 

Description of parameters and buttons in the control area: 
Button Description 

Focus Pos. Indicate the current actual focus position, that is, the actual focal length. 

+ / - Use Jog Speed to adjust the focus position and control the W-axis lens to 
move in the positive/negative direction of the W-axis. 

Text box Desired focal length. 

Locate W-axis moves at Locate Speed to the desired focal length set in the text box. 

To Origin W-axis return to origin. 

Stop W-axis stop the current motion. 
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11.5 Set Laser 
QCW laser can operate in jog and pulse modes. Generally used in welding and precision 
cutting fields. 

 Features: 
o The peak power of a QCW laser is much greater than the average power of 

the laser output. The relationship between both is generally 10 times, for 
example, the average power is 150W and the peak power can reach 1500W. 

o In pulse mode, the peak power, duty ratio, and pulse width are limited to a 
certain range (such as the shaded area in Figure 1 is the operating range of 
the IPG laser in pulse mode). If the actual output relationship is incorrect, the 
laser will stop emit light and issue a corresponding alarm. 

 
 Difference: 

o Control: The main difference in control between QCW laser and ordinary jog 
laser is that it need to follow the QCW laser parameter setting requirements. 
Limit peak power, duty ratio and pulse width setting to avoid setting 
parameter values that are not within the normal working range of the laser, 
causing the laser to alarm. 
Currently supported QCW laser types: QCW laser with peak power, duty 
ratio and pulse width consistent with the working range in Figure 1. 

o Wiring: In general, QCW laser is the same as ordinary jog laser and system 
hardware wiring. The main difference is that the maximum analog input value 
of QCW lasers is 4V. 

Operation Steps: 

 Basic setting: Select laser type and communication method. 

Setting entry: In the menu bar, click Advanced → Laser Device Setting → Basic 

Setting to open the Laser Device Setting page. 
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a. In the Laser Device Setting page, check the Manufacturer in the lower left 

corner and activate the Basic Param area and Communication Param area. 
b. Select the laser type in the Basic Param area and select the communication 

method in the Communication Param area. 
The communication methods supported by each laser type are as follows: 

Communication 
Method 

COM Ethernet Board IO 

Raycus √ × √ 

IPG-YLR √ √ √ 

YLR-K √ √ √ 

Maxphotonics × × √ 

SPI √ × √ 

IPG(US) × √ √ 

IPG(GER) × √ √ 

Linpin × × √ 

Feibo × × √ 

GW × × √ 

JPT × × √ 

Trumpf × × √ 

Nlight × × √ 

Reci × × √ 

Hansphotonics × × √ 

c. In the Burst Param area, set the Delay parameter. 
d. Click Confirm and restart the software to take effect. 

 Set QCW mode 

Setting entry: In the menu bar, click Advanced → Laser Device Setting → QCW 

Mode to open the QCW Mode page. 
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a. In the Laser Device Work Mode area of the QCW Mode page, click QCW. 

Note: After selecting the QCW mode, the laser power parameter value can 
only be set on this page. The power parameter setting entry turn gray in 
other interfaces, such as the burst, cutting and piercing interfaces. 

b. In the QCW Parameters Setting area, set the peak power, duty cycle, 
frequency, and pulse width parameters. 

i. First set the peak power. The peak power determine the maximum 
value of the duty cycle. The relationship between the peak power and 
the duty cycle is as follows: 

 When the range of peak power is [20,100], then 
Maximum value of duty cycle=1000/peak power 

 When the range of peak power is [0,20), then 
Maximum value of duty cycle=50% 

ii. After the duty cycle setting is completed, the maximum value of the 
product of pulse width (ms) and frequency (Hz) is confirmed. The 
relationship is as follows: 
Duty cycle × 10 = pulse width × frequency 

Note: There are the above constraints between peak power and duty cycle, 
pulse width, and repetition frequency. When filling in, if there are errors, the 
input boxes will automatically correct each other's values with the maximum 
value. 

c. Click OK. 

11.6 Monitor Laser 
Check the status of the laser, such as: power level, temperature, water flow, mode, alarm, 
etc. 

Prerequisite: 
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 The laser status is normal. 

 NcStudio software communication is normal. 
Operation Steps: 

1. In the menu bar, click Advanced → Laser Device Monitor. 

2. Optional: Select the host computer software under the target path. Start the laser 
device host computer software. 

Note: After turning on the monitor laser, the path of the laser host computer 
software is automatically saved to the parameter Laser Path, and there is no need 
to select the path again. 

11.7 Custom Command 

11.7.1 Edit Machining and Technic Flow 
According to actual needs, customize technology, machining flow and command in 
NcConfig. 

If you want to open NcConfig and NcStudio at the same time, you need to open 
NcConfig first and then open NcStudio. 

Operation Steps: 

1. Find NcConfig under the installation path C:\Program 
Files\Weihong\NcStudio\NcConfig, and double click to enter the NcConfig interface. 

2. In the menu bar, click View →Configuration. In the pop-up left list bar, double click 

Flow Edit to open the Flow Edit interface: 

 
3. In the Edit Object area, select the target edit object and related processes. 
4. In the Instruction area, select the target command folder and double-click the 

command in the folder to add it to the process. 
5. In the middle area, select the target command, click , , , move up, down or 

delete command. 
6. In the menu bar, select the following method to save edit process: 

o If need to save the current edit process, in the menu bar, click  Save. 

o If need to save the whole edit process, in the menu bar, click  Save All. 
Related Tasks: 

After completing the editing, execute the customized process to check whether it is 
reasonable. For details, please see Custom Instruction Debug. 

11.7.2 Custom Instruction Debug 
When the system is idle, the debugging process has edited the custom command. If no 
custom command has been edited, the debugging command drop-down list will be empty. 

Warning: If the process is written incorrectly, the machine tool may be damaged. Please 
be careful to stop debugging in time during execution. 
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Operation Steps: 

1. In the menu bar, click Advanced → Custom Instructions Debug to pop-up the 

Custom Instructions Debug dialog box: 

 
2. Select the command from the Debugee drop-down box. 
3. Click Run. Exiting the dialog box is not allowed during debugging. If close the dialog 

box, the execution of the debugging action will be terminated. 
During the debugging process, if meet E-stop, click Stop to terminate the execution 
of the current action. 

11.7.3 Disable Action of Flow Edit 
Provide shield or enable expanded machining processes and custom commands. 

Operation Steps: 

1. In the menu bar, click Advanced → Disable Action of Flow Edit to pop-up the 

Disable Action of Flow Edit dialog box: 

 
The actions in the General tab are customized commands. 

2. Disable or enable flow edit action as needed. 

o Disable: That is, the button is set to  status. 

o Enable: That is, the button is set to  status. 
3. After setting is complete, click Apply. 
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12 System Operation 
12.1 Auto Exhaust 
A large amount of smoke will be generated during the laser cutting process, so a smoke 
exhaust fan is added at the bottom of the machine tool to remove the smoke. This 
operation is used to automatically control the fan to turn on to extract smoke during laser 
cutting. 

In the menu bar, click System → System Parameters → External Device. Set the 

manufacturer parameters Enable Auto Exhaust to Yes under the Exhaust category. 
Enable auto exhaust function. 

Set the parameter Exhausting Interval according to the actual fan distribution position, 
and set other exhaust related function parameters according to operation habits. 

12.2 Set Common Parameter 
Common parameter include machine tool motion parameter, user habits, gas parameter, 
burst parameter, follow-up control, gas flushing, and unit switching. 

Operation Steps: 

1. Select the following method to open the Common Param dialog box: 

o In the toolbar, click . 

o In the menu bar, click System → Common Parameters. 

 
2. In the following areas, set common parameters: 

o Machine param (need to check the Manufacturer to activate parameters.) 
o User habits 
o Gas param 
o Burst param 
o Follow 
o Scour by gas 
o Unit switch 

3. Click Confirm to complete the setting change. 
4. If need to switch to system parameters, click System Param. 
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12.2.1 Machine Tool Motion Parameter 
Parameter Description 

Frame check speed The running speed during the cut frame process. 

Range: 0mm~60000mm. 

G00 speed During machine tool machining, each axis G00 speed. 

Range: 1mm~100000mm. 

G00 acc vary time During machine tool machining, the G00 acceleration change time of 
each axis. 

Range: 1mm~10000mm. 

Max.S of ref circle The maximum allowable speed corresponding to a reference circle 
with a diameter of 10mm. 

Range: 1mm~1000000mm. 

G00 acc During machine tool machining, each axis G00 maximum 
acceleration. 

Range: 0.001mm~50000mm. 

Cutting acc During machine tool machining, the total acceleration in the 
acceleration phase. 

Range: 0.1mm~50000mm. 

Axial acc vary time The change time of single-axis acceleration during machining. 

Corner error Maximum error in corner transition. 

Range: 0mm~0.3mm. 

Curve error Arc shrink error after FIR filtering. 

Range: 0mm~1mm. 

 When the value is 0, the vibration suppression coefficient auto 
control error will be used. 

 When the value is less than 0.001, it is treated as 0.001. 

12.2.2 User Habits 
Parameter Description 

Do piercing at 
resume 

When coarse cutting, need to enable breakpoint resume piercing. 

When breakpoint resume, if need to set the retract distance, please set the 
parameter Breakpoint Resume Retract Distance in the system parameters. 

Action after end Including none, back to mark position, back to fixed point, back to work origin and 
other additional behaviors of the X-axis and Y-axis after machining is completed. 

12.2.3 Gas Param 
Parameter Description 

Default gas type Open the blow port to use the default gas. When the user choose to blow O2, the 
proportional valve enable port will be opened. 

Gas change 
delay 

Mainly used for increment piercing and segment piercing. If the cutting gas is 
different from the piercing gas, the laster will not be turned off during the delay 
process of switching gas after the piercing is completed. 

1st point blow 
delay 

Blow delay after machining start/breakpoint resume. 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 143 / 161 

Parameter Description 

Blow delay When the blow port switche from OFF to ON status, the blow delay will be executed. 

P. in idle The pressure value of manual blow in idle status. 

Gas ON 
distance 

The maximum straight line distance between two primitives switching without gas 
OFF. 

12.2.4 Burst Param 
Parameter Description 

Power Set the laser intensity during burst. 

Frequency The frequency of pulse emit light during burst. 

Duty ratio Corresponds to the duty ratio during burst. 

Delay The laser ON duration when performing burst. 

12.2.5 Follow 
Parameter Description 

Enable leapfrog Whether to enable leapfrog function. 

Lifting Min. dis When the distance is less than this value, the cutting head not perform leapfrog 
and directly traverse to the next start point of the figure. 

Follow Max. H. When the cutting height/piercing height is less than this value, it will directly follow 
to the set height; when the cutting height/piercing height is greater than this value, 
it will first follow to 1mm and then lift to the set height. 

Z up Pos. The machine coordinate position of the Z-axis berth when turn off follow after 
return to the machine origin or machining is completed. 

Fixed height After enable fixed height cutting, the follow-up is not enabled during the cutting 
process, and the Z-axis is fixed at a Fixed Height Position. You can move to 
actual height, click to get the position or manual input. 

12.2.6 Scour by Gas 
The scour by gas function blow before cutting, which is used to clean the nozzle and at the 
same time make the gas more clearly in the tube to ensure the actual cutting quality. 

Parameter Description 

Enable Whether to enable gas flush function. 

Gas pressure The percentage of pressure used during gas flush. 

Duration The duration for perform once gas flush. 

Interval The time between flushes when flush times is greater than 1. 

Times before start The times for gas flush when start machining. 

Times in resume The times for gas flush when execute breakpoint resume. 

12.3 Detect Encoder 
Detect whether the encoder feedback and the rotation direction of the motor are consistent, 
and automatically calculate the number of feedback pulses per turn and the encoder 
direction. 

Before detect the encoder, make sure the following parameters are correct: 

 Drive parameter. 

 Each axis pulse equivalent. 
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 Axis direction. 

 Per turn command pulse number. 
Operation Steps: 

1. Move the X-axis and Y-axis to the middle position of the machine tool's stroke to 
ensure that there is enough stroke for detection. 

2. In the menu bar, click System → Hardware Diagnose → Encoder Detection to 

open the Encoder Detection dialog box: 

 
3. Optional: If need to automatically write system parameters after detection, check 

Automatically Write Detection Values after Detection. 
4. Optional: If need to set the XY step distance, set XY step distances in the Settings 

area. 
The default distance is 10mm, which is generally set to one pitch length to minimize 
detection errors. 

5. In Control Panel area, click Start. 

12.4 Other Software Setting 

12.4.1 Switch Language 
Currently, the software support more than ten languages. 

In the menu bar, click System → Language, select the language to switch under the 

submenu, and restart the software to take effect. 

12.4.2 Switch Unit 
Support metric and inch units. 

In the menu bar, click System → Unit, select the unit to switch under the submenu, and 

restart the software to take effect. 

12.4.3 Switch Theme 
Support black and white themes. 

In the menu bar, click System → Theme, select the theme to switch under the submenu, 

and restart the software to take effect. 

12.4.4 Change Password 
Change manufacturer password. 

In the menu bar, click System → Change Password, enter the old password and new 

password in the pop-up dialog box, and the changes will take effect immediately. 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 145 / 161 

13 System Maintenance 
13.1 Generate Installation Package 
Generate the whole installation program in the current CNC system. It is helpful to back up 
system files and save stable versions of system software. 

Operation Steps: 

1. In the menu bar, click File → Generate Installation Package to open the Packup 

Tool dialog box:  

 
2. Modify the installation package name and select the installation package storage 

path. 
3. Optional: Click Advanced and set the following parameters: 

 
The parameter description of advanced setting is as follows: 

Parameter Description 

Language Support more than ten types of languages. 

Auto boot Whether to auto start the software when turn on the computer. 

Parameter migrate ▪ Save all local parameters. 

▪ Only save local machine specific parameters. 

▪ New installation: Not keep any parameters, use the initial parameters of the 
software. 

Support language 
selection 

Whether to support language selection during installation. 

Start the software after 
installation 

After the installation is complete, auto start software. 
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Parameter Description 

Check setup 
environment 

When installing this installation package, check whether the Windows 
environment of the current computer meet the software running requirements. 

4. Click Pack Up. 
After the installation package is created, view the generated installation package in the 
selected storage path. 

13.2 View Log 
The log record important user operations, system events and time, including information 
and historical information after this system startup. 

Every time the log file exceeds 50M, a backup log file (NcStudio_xxxx.log) is automatically 
generated in the User folder (path), and the original log content is cleared. 

Operation Steps: 

1. Select the following methods to open the Log dialog box and view the log: 
o In the running information bar, double click Alarm/Log. 

o In the menu bar, click System → Log. 

 
2. Select the log type to view: 

o Click Show Info button to display the software running status information 

with the  icon. 

o Click Show Alarms button to display the warning information with the  
icon. 

o Click Show Errors button to display the error information with the  icon. 
o Click All Logs button to display all corresponding log information since the 

system was started. 
Buttons are highlighted by default. 

3. Optional: If you want to view more log information, click Query History and select 
the date to view. 
Maximum of 1 year of log information can be viewed. 

4. Optional: If need to delete all log information, click the Clear button. 

Note: Please clear the system log regularly! Otherwise, when the system log file is 
too large, it will affect the performance and response time of the system. 
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13.3 Register Board Card 
It is used to restrict the system usage time. 

Before registering the board card, make sure the machine tool is in idle or E-stop status. 

Accounting to the following steps to register the board: 

1. Get Registration Code 
2. Register Board Card Usage Time 

13.3.1 Get Registration Code 
Prerequisite: 

1. Select one of the following methods to obtain an account: 
o Contact local sales. 
o Dial 400-882-9188. 

2. Fill in Registration Information Confirmation Letter and send it to Weihong Company 
after sealing it. 

Operation Steps: 

1. In the menu bar, click Help → About to open the NcStudio dialog box: 

 
2. Record the device No. 

The device number changes with the registration times and can be judged by the 
last three digits of the number. 
For example: when the registration times is 0, the last three digits are 000; when the registration 
times is 1, the last three digits are 001. 

3. Enter into WEIHONG official account in WeChat. 

4. Click Service → Register → Activate Account, enter your mobile phone number, 

and obtain the temporary login password. 
The temporary login password will be sent to the entered mobile phone number in 
the form of a text message, please pay attention to check the text message. 

5. Return to the login interface, enter the temporary login password to log in, and fill in 
the information as shown to obtain the registration code: 
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If need to reset the password, click  to enter the account management interface to 
reset the password. 

13.3.2 Register Board Card Usage Time 
Operation Steps: 

1. In the menu bar, click Help → About to open the NcStudio dialog box: 

2. Click Register and enter the registration code in the pop-up dialog box. 
For details, please see Get Registration Code. 

After registration is completed, restart the software to take effect. 

When using the software later, you can check the remaining registration time in the 
NcStudio dialog box. 

13.3.3 FAQ 
Include: 

 After the registration time expires, please register again if you want to continue 
using it. 

 If the current board card and software do not match, please contact the 
manufacturer in time. 

13.4 Install and Use Camera 
When installing the NcStudio V15 Laser Cutting Control System, you can select 
whether to enable the camera function to monitor the on-site machining status and 
facilitate control machining. 

Camera types are currently only supported: Hikvision, Dahua. 

Accounting to the following steps to install and use the camera: 

1. Connect the camera to the PC. 
Up to two cameras can be connected at the same time. 

2. According to the camera type, select the following methods to obtain the camera's 
IP address, port, subnet mask and default gateway information: 

o Hikvision: Install SADPTool.exe software to check. 
o Dahua: View it through the Dahua camera manufacturer manual. 
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3. Select one of the following methods to modify the IP address: 
o Modify Computer IP Address 
o Modify Camera IP Address 

13.4.1 Modify Computer IP Address 
Accounting to the following steps to modify the computer IP address: 

1. The network connection name take Ethernet 3 as an example. Accounting to set 
the PC address based on the obtained camera address information. Accounting to 
the following steps to connect the PC and camera: 

a. Click Control Panel → Network and Sharing Center → Ethernet 3 to open 
the Ethernet 3 dialog box. 

b. Click Properties → Internet Protocol Version 4 (TCP/IPv4) → OK. 
c. Select Use the Following IP Address to set the computer IP address and 

camera IP in the same network segment, and click OK: 

 
When setting, the first three segments of the IP address, subnet mask and 
default gateway must be the same as those of the camera, and the last 
segment of the IP address must be different from that of the camera. 

2. In the NcStudio software, click System → System Parameters, find the system 

parameter Enable Camera under the 3.0 Monitoring category and set it to Yes in 
the menu bar. 

3. In the camera monitoring area, right click to pop-up the shortcut menu, click Login, 
and the Login dialog box will pop-up: 
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4. Select the camera type, enter the IP address, port number, user name and 

password of the camera. 
After logging in, the camera monitoring area will display the on-site machining status 
captured by the camera. 

If need to zoom in a certain monitoring area, you can view the monitoring content more 
clearly. Double click on one of the camera areas. Double click again to exit the full status 
of a single camera. 

If the camera is replaced later, in the camera monitoring area, right click to pop-up the 
shortcut menu, click Logout and log in again according to the above steps. 

13.4.2 Modify Camera IP Address 
Since the operation steps of Hikvision and Dahua are the same, we will introduce Dahua 
camera as an example. Accounting to the following steps to modify the camera IP address: 

1. Open the online browser, enter the camera IP address, and the login page will pop-
up. 

2. Contact the camera manufacturer to obtain the initial password and log in: 

 
Note: For the first login, the password needs to be changed. 

3. Accounting to the following steps, open the TCP/IP dialog box: 
a. In the upper right area, click Set. 
b. In the left list, click Network Set. 
c. In the Network Set drop-down box, click TCP/IP. 
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When setting, the first three segments of the IP address, subnet mask and default 
gateway must be the same as those of the computer, and the last segment of the IP 
address must be different from that of the computer. 

4. Click Connect to view TCP Port. 

5. In the NcStudio software, click System → System Parameters, find the system 

parameter Enable Camera under the 3.0 Monitoring category and set it to Yes in 
the menu bar. 

6. In the camera monitoring area, right click to pop-up the shortcut menu, click Login, 
and the Login dialog box will pop-up: 

 
7. Select the camera type, enter the IP address, port number, user name and 

password of the camera. 
After logging in, the camera monitoring area will display the on-site machining status 
captured by the camera. 

If need to zoom in a certain monitoring area, you can view the monitoring content more 
clearly. Double click on one of the camera areas. Double click again to exit the full status 
of a single camera. 

If the camera is replaced later, in the camera monitoring area, right click to pop-up the 
shortcut menu, click Logout and log in again according to the above steps. 

13.5 Machine Maintenance Regular Reminder 
Machine maintenance reminder, as an essential function of every machine tool, can well 
remind customers to maintain the machine tool. The current machine tool maintenance 
reminder functions are as follows: 
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 Support customizing the content of maintenance reminders. For the default content 
of maintenance reminders, it can also be changed through manual editing 
permissions. 

 All content support import and export, which is convenient for subsequent large 
updates, and the content can be directly imported without manual editing again. 

 Distinguish between the authority of the manufacturer and the operator. When 
some particularly important maintenance content need to be canceled under the 
authority of the manufacturer (confirmed by the manufacturer), the authority of the 
operator cannot be reset at will to avoid damage to the machine tool components. 

13.5.1 Function Entry 

In the menu bar, click System → Machine Maintenance Regular Reminder. 

 
 

13.5.2 Page Display Information Description 
Parameter Description 

Name The maintenance item name must be unique. 

Period/Unit Choose between time/distance cycle. 

▪ Time cycle description: How many days do maintenance needs to be carried out; the 
number of days is the world time obtained by computer. 

▪ Distance cycle description: The machine tool needs to be maintained for every meter it 
runs; the distance is the movement distance of the machine tool. 

Progress The degree of progress in the maintenance cycle. 

Notify type Choose between alarm/notification. 

▪ Alarm: The progress is displayed in red and an alarm dialog box pops up.  

▪ Notification: The progress is displayed in red and a "warning" log is generated. 

Description Description of maintenance items, requiring clear and unambiguous explanation of 
maintenance content. 
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Parameter Description 

Permissions Operator/manufacturer choice. Differentiate operations with different permissions. 
Reminder content for machine tool maintenance with manufacturer authority: 

▪ Operator permissions cannot be reset. 

▪ After reaching 100% progress, you need to enter the manufacturer's password to 
confirm completion. 

13.5.3 Functional Operation Instruction 

  Select the operation permission, if it is not checked, it means the 
operator permission, and you can only view the history record and reset the 
maintenance content items of the operator permission. 

 History record: Display reset maintenance items, prompt/alarm content and 
completion status. 

 Reset: Start the progress of existing maintenance items from zero. 

 Edit: Modify existing maintenance items. 
Modify the "maintenance cycle" of an existing maintenance item, and the progress 
will be calculated based on the new cycle and will not start from 0. Modify other 
content will not affect the progress. 

 Add: Added maintenance items. 

 Delete: Delete existing maintenance items. 

 Export: Save the content of the current maintenance item to the current computer, 
the format is .dat, and the file name can be customized. 

 Import: Import the content of the local maintenance items into the software in the 
format of .dat. 
Import rules: Subject to "name". Projects with the same name will not be imported. 
If projects with different names are imported, the progress will be calculated from 0. 
For existing maintenance items before importing, the progress will not affect after 
import. 
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14 Handle Introduction 
The WHB05 series wireless motion control handles are independently designed and 
developed by Weihong Company and customized and produced by Chengdu 
Xinhongchang. Among them, those adapted to Weihong Company NcEditor V15 laser 
cutting control system include: 

 WHB05L(V4) wireless handle: Suitable for sheet and tube integration. 

 WHB05L(V5) wireless handle: Suitable for sheet and tube integration. 
The WHB05 series wireless handle consists of two parts: handheld operation panel 
(transmitter) and USB receiver. 

It can move freely within 40 m open area without being limited to the computer. The 
machining positioning is convenient, and the operation efficiency and material utilization 
rate are greatly improved. 

14.1 WHB05L(V4) Wireless Handle 
WHB05L is an upgraded version of WHB05S, adding W-axis (rotary axis) zero return 
control and some other function control buttons. 

WHB05L(V4) wireless handle diagram as follows: 
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WHB05L(V4) wireless controller function button functions are defined as follows: 
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14.2 WHB05L(V5) Wireless Handle 
WHB05L(V5) is the button text of WHB05L(V4) upgraded to an icon form version, which 
facilitates the image memory of functions. 

The rotation axis of WHB05L(V5) is the B-axis. 

WHB05L(V5) wireless handle diagram as follows: 
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WHB05L(V5) wireless controller function button functions are defined as follows: 
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14.3 Product Specification Parameter 
Electrical Parameter 

 Handheld terminal operation voltage current: 2 AA batteries, 3V/6mA 

 Handheld terminal low voltage alarm range: <2.2V 

 Handheld terminal transmit power: 14dB 

 Receiver receive sensitivity: -90dB 

 Wireless communication frequency: 433MHz band 

 Delay time: 32ms 
Other Parameter 

 Button use life: 400,000 to 500,000 times 

 Wireless communication distance: 40m in open environment 

 Working temperature: -25°~70° 

 Anti fall height: 1.5m 

 Receiver port: USB2.0 

 USB receiver: Comes with 1.5m USB double layer shielded cable 

 USB communication transmission distance: ≤5m 

14.4 Precautions for Use 
Please note the following: 

 Before start the software, please make sure the wireless controller is connected. 

 The handle's operation panel and USB receiver are paired one-to-one, please do 
not mix them. 

 When the yellow warning light on the handle light up, it means that the battery is 
about to run out. Please replace the AA battery as soon as possible to avoid affect 
normal operation. 

 Please not fix the signal receiver inside the electrical cabinet to avoid affect signal 
reception. 

14.5 FAQ 
When using the wireless handle, if the following situations occur: 

 After pressing the button, the machine tool action response is delayed. 

 After pressing the button, the machine tool not respond. 

 After pressing the button, the button automatically pop-up. 
Please check the usage environment and usage method of the wireless handle: 

Usage Environment: The wireless handle is used indoors and placed in a metal 

cabinet. USB extension cable is not used. The communication distance is ≤2m. 

 Reason: Metal cabinets have a shield effect on wireless signals, causing unstable 
wireless transmission and causing abnormal situations. 

 Solution: Place the receiver outside the cabinet to ensure no obstruction. 
Usage Environment: The wireless handle is used indoors and placed outside the 
metal cabinet. Using a 2~3m USB extension cable, the communication distance is 
10m. 

 Reason: Using an extension cable will increase the instability of USB 
communication. When interference is severe, USB communication may be 
abnormal, resulting in delayed remote control operation. 

 Solution: Not use extension cable. 
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15 Shortcut Key List 
When using the NcStudio-V15 Laser Cutting Control System, refer to the following 
shortcut keys for easy operation: 

 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 160 / 161 

Legal Notices 
The term “Software Product” includes all copies of the licensed software and its 
documentation. This license agreement is a legal agreement between You (either an 
individual, a legal entity or any affiliated companies or other entities) and Weihong 
Electronic Technology Co., Ltd. (hereinafter referred to as Weihong Company). By 
installing, copying, or otherwise using the Software Product, you agree to be bound by the 
terms and conditions of this license. Unless otherwise stated in this agreement, you shall 
not use, copy, revise, rent, or transfer the Software Product or any part of the Software 
Product for any other purposes. 

Requirements of Use 
1. You may install for use one copy of the Software Product on a single machine; 
2. You may make a copy of the Software Product for archive or backup purposes and 

the copy is to be used on this machine only; 
3. You may transfer the Software Product and the license agreement to a third party, 

provided that the third party accepts the terms and conditions stated in this 
agreement, with prior express permission from Weihong Company; 

4. When transfer confirmed, you shall transfer all the copies of the original documents 
and the supplementary documents to the third party or destroy all the copies un-
transferred; 

5. You can use the Software Product on a network server or intranet server only if it is 
stipulated in explicit terms that you are allowed to use the Software Product on a 
network server or intranet server, or you have purchased license for each node and 
terminal using the Software Product; 

6. You may NOT sublicense, assign or transfer the license agreement; 
7. You may NOT or direct any third party to reverse engineer, decompile or 

disassemble the Software Product; 
8. You may NOT copy or transfer the Software Product or any part of the Software 

Product unless otherwise expressly stated in this agreement; 
9. The license agreement shall be terminated automatically upon you transfer the 

Software Product or copies of all or part of the Software Product to a third party. 

Intellectual Property Rights Notice 
The Software Product and all intellectual property rights therein (including but not limited to 
any all copyrights, patents, trademarks, and publicity rights) are owned by Weihong 
Company. The Software Product is protected for Weihong Company on the basis of 
Chinese copyright law and international treaty provisions as well as on the basis of other 
laws and agreements regarding intellectual property. You are not allowed to remove the 
copyright statement made in the Software Product, and guarantee that you shall copy the 
copyright statement in all copies of the Software Product or of any part of the Software 
Product. You are obliged to stop any form of illegal copying of the Software Product and 
accompanying materials. 

Weihong Company can update the Software Product at any time. You can pay real-time 
attention to Weihong Company's official website. 
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Termination 
This license may be terminated by Weihong Company at any time once you violate any 
terms or conditions made in this agreement. Once the license is terminated, you are 
obliged to destroy all the copies of the Software Product or return them to Weihong 
Company. 

Now, we affirm that you have already read through this agreement and understood it 
thoroughly and agreed to comply with all of the terms and conditions of this agreement 
strictly. 

Weihong Electronic Technology Co., Ltd. 
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